
©200, .Ibrahim I. Hamarash, MS-Access Lab Manual, Database Systems, Dept. of Software Eng., Erbil.       
 
 

1

 

College of Engineering 
Department of Software Engineering 

Erbil, Kurdistan 
 

 

 

Introduction to 

Microsoft Access 2000 

Lab Manual 
 
 
 
 
 

Dr. Ibrahim I. HAMARASH 
Assist Professor 

 
 
 
 
 
 
 
 

 
 



©200, .Ibrahim I. Hamarash, MS-Access Lab Manual, Database Systems, Dept. of Software Eng., Erbil.       
 
 

2

 

Contents 
 
 
Practical 1……………………………………………………………………………..3 
Introduction to Access basics. Getting help in Access. Creating databases and 
tables. 
 
 
Practical 2……………………………………………………………………………16 
More on creating, editing and printing tables. 
 
 
Practical 3…………...……………………………………………………………….21 
Creating and using customized forms. 
 
 
Practical 4……………...…………………………………………………………….34 
Creating queries using Query-By-Example (QBE). Creating relationships between 
tables. 
 
 
Practical 5………………..………………………………………………………….44 
Searching for values using filters. Sorting records. Creating a form that contains a 
subform. 
 
 
Practical 6………………………………….……………………………………….53 
Creating, previewing and printing customized reports. Creating database applications. 
Creating startup forms. Automating repetitive tasks using macros and the Command 
Button Wizard. 
 
 
Practical 7…………………………………………………………………………..64 
More on field and table properties. Creating indexes. More on creating relationships 
between tables. 
 
 
Practical 8………………………………………………………………………….75 
Creating parameter queries. Using Access SQL.  

 

 
 
 
 
 

 
 



©200, .Ibrahim I. Hamarash, MS-Access Lab Manual, Database Systems, Dept. of Software Eng., Erbil.       
 
 

3

 
Practical 1 

 
 
In this practical we will look at the basics of Microsoft Access. You should first read 
the information given in this practical and then complete the activities listed 
throughout. 
 
 
Starting and Quitting Microsoft Access
 
To start Microsoft Access   
 
Click on the Windows Start button; select Programs, then Microsoft Access.    
Or, if displayed on the screen, double-click on the Microsoft Access icon. 
   
 
 
To quit Microsoft Access   
 
Choose Exit from the File menu. 
 
 
Getting Help using Microsoft Access 
 
There are many ways to get assistance when using Microsoft Access. Many of the 
help options are available through the Help menu or by selected the Microsoft 
Access Help button on the toolbar. 
 
Access Wizards 
 
When you create a new database, table, query, form or report, Microsoft Access 
displays a dialog box where you can choose whether to start with a blank object and 
build it yourself or use an Access Wizard to help you build it. An Access Wizard is 
like a database expert who prompts you with questions about the object you want 
and then builds the object based on your answers. 
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Activity P1-1 
 
Practise using the Microsoft Access help facilities. Search for help or ask questions 
on the following topics: creating tables, data types, primary key, and the data 
validation . 
 
 
 
 
Opening a Database
 
A Microsoft Access database is a collection of objects, not just a single table of data. 
One database file contains the tables as well as queries, forms, reports and other 
objects that help you use the information in the database.  
 
When you first load Access, the Microsoft Access dialog box is displayed, as shown 
in Figure P1-1. 
 

 
 
 

Figure P1-1: The Microsoft Access dialog box. 
 
 
To Open a Database using Microsoft Access dialog box 
 
To view existing databases select the Open an existing file option. The window lists 
the most recently opened databases, however if you wish to open a database that is 
not listed highlight More Files. Once you have made your selection click on OK to 
continue or Cancel to cancel the operation.  
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To Open a Database 
 
If the Microsoft Access dialog box is not displayed choose Open from the File menu 
(or click the Open button on the toolbar).  

 
This displays the Open dialog box. Once you have located your database and 
identified the file name, choose Open. Microsoft Access provides sample databases 
in the C:\Program Files\Microsoft Office\Office\Samples folder. 
 
 
The Database Window
 
When you create or open a database, Microsoft Access displays a Database window 
in the Microsoft Access window.  The Database window is your command centre.  
From here, you can create, edit and use any object in your database. For example, 
the Database window for the Northwind database (sometimes called the NWIND 
database) is shown in Figure P1-2. 
 

 
 

 
Figure P1-2: The Microsoft Access Database window 

for the Northwind database. 
 
 
The object buttons in the Database window provide direct access to every object in 
your database. For example, to see a list of forms in the database, click the Forms 
button. Microsoft Access displays the list of forms stored in the database. To return 
to the list of tables, click the Tables button. 
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Viewing Data and Closing a Database
 
To view data in a table 
 
1. In the Database window, click the Tables button to display the list of tables in the 

database. 
 
2. Double-click the name of the table you want to see.  
 
Microsoft Access displays the table in Datasheet view. Datasheet view displays data 
from the table in columns and rows, similar to a spreadsheet.  In a datasheet, you 
can resize and rearrange the columns (fields) and resize the rows (records). You can 
scroll vertically to see more records and horizontally to see more fields. 
 
3.  When you’re ready to return to the Database window, close the Datasheet 

window. 
 
Or to view the database window while leaving the object (e.g. datasheet) open, click 
the Database Window button on the toolbar.      

            
    
It’s just as easy to see a query’s dynaset as it is to see a table. A dynaset is an 
updatable type of record set, which is any Microsoft Access set of records defined by 
a table or query that you can treat as an object. Click the Queries button in the 
Database window, and then double-click the query you want to view.  Microsoft 
Access displays the dynaset in datasheet view. 
 
You use the same technique to view a form. 
 
To view data using a form  
 
1.  In the Database window, click the Forms button to display the list of forms. 
 
2.  Double-click the name of the form you want to view. Microsoft Access opens the 

form and displays the first record of data.  
 
You can also display a form in the Datasheet view. To switch from Form view to 
Datasheet view, access the View menu and select Datasheet.    
   
 
To close a database 
 
1.  Switch to the Database window if it isn’t active.  
 
2. From the File menu, choose Close. 
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Activity P1-2 
 
Open, view and close the various objects in the Northwind database. Note that some 
objects in this database only allow you to see the data in form view and not in 
datasheet view. 
 
 
 
 
Creating a Database 
 
When you create a Microsoft Access database, you create one file that contains all 
the tables in your database as well as the queries, forms, reports and other objects 
that help you use the information in the database. 
 
Microsoft Access provides two methods to create a database. You can create a 
blank database and then add the tables, forms, reports and other objects later and 
this is the most flexible method, but it requires you to define each database element 
separately. Or you can use a Database Wizard to create in one operation the 
required tables, forms and reports for the type of database you choose and this is 
the easiest way to start creating your database. Either way, you can modify and 
extend your database at any time after it has been created. 
 
In the following sections, we describe how to create a database using a Database 
Wizard and then how to create a blank database. 
 
To create a database using the Database Wizard 
 
1. In the Microsoft Access startup window, choose New from the File menu. 
 
2. The New dialog box is displayed. Choose the Databases option to list the range 

of databases that you can create with the Database Wizard. To select the 
database you need, double-click the icon. The wizard will create what you need 
to store, enter and summarize your data. 

 
To create a database (without Database Wizard) 
 
1.  In the Microsoft Access startup window, choose New from the File menu. Or click 

the New button on the toolbar.       

 
   

Microsoft Access displays the New dialog box. The General option displays the 
File New dialog box that allows you to create a database from scratch and gives 
your new database a default name (e.g. db1), which you can replace with the 
name of your choice.  
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2. In the File name box, type the name of your database. A database name can 
contain up to 64 characters. Microsoft Access automatically appends a mdb 
extension to your database filename. 

 
3. To store the database in a different directory or drive, select the location of the file 

you want in the Save in list.  
 
4. Choose Create. Microsoft Access creates an empty database file and opens the 

Database window. 
 
 
 
 
Activity P1-3 
 
Create a new blank database called StayHome.mdb and save it to your network 
folder. This database will hold the tables, forms, reports and other objects for a video 
rental shop. 
 
 
 
Create a Table 
 
Microsoft Access provides three ways to create a blank (empty) table: 
 
• Use the Database Wizard to create in one operation all the tables, forms and 

reports required for an entire database.  
• Use Design view to specify all of your table details from scratch. Use the Table 

Wizard to choose the fields for your table from a variety of predefined tables such 
as business contacts, household inventory or medical records. 

• Enter data directly into a blank datasheet. When you save the new datasheet, 
Microsoft Access will analyse your data and automatically assign the appropriate 
data type and format for each field. 

 
Regardless of which method you use to create a table, you can use table Design 
view at any time to customize your table further, such as adding new fields, setting 
default values or creating input masks. 
 
In the following sections we will describe in more detail the process of creating a 
table using a Table Wizard and then how to create a table using design view. 
 
To create a table using the Table Wizard 
 
1.  Start Microsoft Access, and open the database that is to contain the table. 
 
2.  In the Database window, click the Tables button, and then choose the New 

button.  Or select the Insert menu and choose Table. Microsoft Access displays 
the New Table dialog box, as shown in Figure P1-3. 
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Figure P1-3: New Table dialog box. 
 
3.  Choose the Table Wizard option. 
 
4. You are then prompted to make appropriate choices as you create your table 

using the Table Wizard. To display the next Table Wizard dialog box, choose the 
Next button. The final dialog box offers you the options to further modify your 
table, add rows to the table, create a form based on your table using the Table 
Wizard or finish. 

 
To create a table using Design view 
 
1. In the Database window, click the Tables button and choose the New button (or 

choose Table from the Insert menu). 
 
2. The New Table dialog box is displayed (as shown in Figure P1-3).  
 
3. Choose the Design View button to open a blank Table window in Design view, 

as shown in Figure P1-4. 
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Figure P1-4:  Table Design view. 
 
 
Plan Fields and Data Types 
 
The Field Name identifies the data stored in a field.  A field name can contain up to 
64 characters, including spaces. The Data Type tells Microsoft Access what kind of 
data goes in the field, such as text, numbers, dates or currency.  
 
A brief description of the most commonly used data types is given below: 
 
The Text data type is used for words (such as names), for combinations of words 
and numbers (such as addresses), and for numbers that are not used in 
mathematical calculations (such as telephone numbers). 
The AutoNumber data type stores sequential numbers created by Microsoft Access.   
The Date/Time data type is used for dates and times.  
The Number data type is used for numbers that can be used in mathematical 
calculations, and also for fields that are related to other Number fields or to 
AutoNumber fields.  
The Currency data type is used for currency values such as francs, dollars, or yen.  
The Yes/No data type is used for yes or no, true or false values. 
The Memo data type is used to store long textual descriptions up to a maximum size 
of 64,000 characters. Memo fields cannot be indexed.  
 
 
More Information  For details about data types, click in the Data Type column and 
press F1. 
Add Fields to the Table 
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To add a field 
 
1.  Type the name of the field to be added in the first empty box under Field Name. 
 
2.  Press TAB to move to the Data Type box. Microsoft Access gives the field a Text 

data type.  However, if the field is not text, you’ll need to select the appropriate 
data type. 

 
3.  To open the list of alternative data types, click the arrow or press ALT+ DOWN 

ARROW. 
 
4. Press TAB to move to the Description box. If required, you may enter in a short 

description for each field to help you remember the purpose of the field. 
 
Set Field Properties 
 
Each field in a table has a set of properties.  By changing a field’s properties, you 
can control how Microsoft Access stores, handles, and displays data in a field.  For 
example, you might want your data displayed in a particular format – numbers in 
scientific notation, perhaps, or dates with the month’s name abbreviated. The Format 
property controls how data is displayed in datasheets, forms, and reports. 
 
To set a field property 
 
1.  Click any box in the row that defines the field to be set. 
 
2. Click the box of the required property, and then set or select the appropriate 

property setting. 
 
To delete a property setting 
 
Select the setting for the property of the field, and then press the Delete key 
 
More information  For more information about an individual field property, click the 
property and press F1. 
 
To set a primary key for a table 
 
Open the table in Design View and select the appropriate row(s) that form the 
primary key for the table. Then select the Primary Key button on the toolbar. 

 
 
A key icon will appear in the column to the left-hand side of the field or fields 
selected to be the primary key. You can also set a primary key by selecting the Edit 
menu and then choosing Primary Key. 
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To save a table 
 
1.  From the File menu, choose Save (or click the Save button on the toolbar). 

  
  
2.  If you are saving the table for the first time, type a name for the table and choose 

OK. 
 
 
To modify the design of an object 
 
1.  In the Database window, click the button for the type of object (e.g. Tables, 

Forms) that you want to modify. 
 
2.  In the list that is displayed, select the object you want to modify. 
 
Choose the Design button. Microsoft Access opens a window for the object and 
displays it in Design view. 
 
Activity P1-4 
 
In this practical you will create four tables for the StayHome database using Design 
view. The tables are Member to hold members details, Video to hold details of 
videos, VideoForRent to hold the details of copies of videos for rent, and 
RentalAgreement to hold the details of video rentals by members. 
 
The Member table has the following fields (with the data type of each in brackets): 
memberNo (AutoNumber), fName (Text), lName (Text), sex (Text), DOB 
(Date/Time), address (Text), dateJoined (Date/Time), comments (Memo) 
The primary key is memberNo 
(Also for this table, set the format property of the Sex field to a field size of 1 with an 
Input Mask >L. Also, set this field with a Validation Rule =‘M’ or ‘F’ and Validation 
Text Please enter M or F. If you do not understand the purpose of the properties 
associated with each field, remember to use the help facility using the F1 key). 
 
The Video table has the following fields (with the data type of each in brackets): 
catalogNo (Text), title (Text), category (Text), dailyRental (Currency), price 
(Currency), directorNo (Text) 
The primary key is catalogNo 
 
The VideoForRent table has the following fields (with the data type of each in 
brackets): 
videoNo (Text), available (Yes/No), catalogNo (Text) 
The primary key is videoNo 
 
The RentalAgreement table has the following fields (with the data type of each in 
brackets): 
rentalNo (AutoNumber), dateOut (Date/Time), dateReturn (Date/Time), memberNo 
(Text), videoNo(Text) 
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The primary key is rentalNo 
(Also for this table, set the format property for the dateOut and dateReturn fields to 
Medium Date format, e.g. 10-Oct-00. If you do not understand the purpose of the 
properties associated with this field, remember to use the help facility using the F1 
key). 
 
 
 
 
Add and Save Records 
 
Each table in your database has two views: Design view and Datasheet view. You 
add records to the Datasheet view. 
 
To switch to Datasheet view 
From the View menu, choose Datasheet or click on the Datasheet button. The

  
arrow to the right of the button lists the alternative views of the table. 
 
To add a record of data 
 
Type in the data values and press TAB to the next field. 
  
To save a record of data 
 
Once you have entered all of the required records, press TAB to move to the first 
empty field below these records. 
 
You do not require to do anything else to save your data. When you leave a record, 
either by moving to another record or by closing a table, Microsoft access 
automatically saves the data. 
 
Edit Records and Close a Table 
 
To edit records 
 
There are various ways to edit records. For example: 
 
To move to the next or the previous field, press TAB or SHIFT+TAB, respectively. 
To select or deselect the current field, press F2. 
To undo changes to the current field or record, press ESC. 
To replace the value in a field with the value of the same field in the previous record, 
press CTRL+’. 
 
To close a table 
 
From the File menu, choose Close. 
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Activity P1-5 
 
Add about 5 records into your Member and Video tables and at least 10 records into 
your VideoForRent and RentalAgreement tables using your own data. The 
VideoForRent table should hold details of copies of videos described in your Video 
table and the RentalAgreement table should record the members described in your 
Member Table renting copies of videos described in your VideoForRent table.   
 
Reopen your tables and practise editing your records. Finally, save and close your 
table and exit from the StayHome database.  
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Practical 2 
 
 
In this practical, you will learn more on how to edit the structure of tables and how to 
work with tables. You should first read the information given in this practical and then 
complete the activities listed throughout. 
 
 
Delete, Insert, and Rearrange Fields in a Table 
 
In a table’s Design view, you can easily review and edit all the fields in the table.  You 
can delete fields or insert new fields wherever you want them.  You can also rearrange 
fields to whatever order you want.  Rearranging the fields in Design view rearranges 
the order of columns, or fields, in Datasheet view. 
 

Use the View    and   buttons on the toolbar to switch between Design view 
and Datasheet view. 
 
To rearrange fields 
 
1.  Open the table in Design view and then select the row to be rearranged by clicking 

its row selector. The row selector is the first column (shaded) on the left-hand side 
of the table . 

 
2.  Click the row selector again, hold the mouse button down, and then drag the row to 

the required position in the table. 
 
3.  When the pointer is where you want the row placed, release the mouse button. 

Microsoft Access moves the field. 
 
To delete a field 
 
1. Open the table in Design view. 
 
2. Select the row that defines the field you want to delete by clicking its row selector. 

From the Edit menu, choose Delete or Delete Rows. (Alternatively, you can press 
the Delete Rows button on the toolbar).  

 
3. Microsoft Access deletes the field and all its data from your table.  
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To insert a new field above an existing field 
 
1. Click the row above which you want the new row to appear. 

2.  From the Insert menu, choose Rows (or press the Insert Rows button    on the 
toolbar). Microsoft Access inserts an empty row above the current row. 

 
3.  Define your new field in the empty row. 
 
 
Activity P2-1 
 
Restructure the Member table by deleting the comments field. Restructure the Video 
table by inserting a new field called certificate (Text) below the title field. Restructure 
the RentalAgreement table by moving the memberNo and videoNo fields before the 
dateOut field. Save your newly restructured tables.  
 
 
 
Create a Field that Looks up or Lists Values in Tables 
 
Using the Lookup Wizard, you can create a field that displays either of two kinds of 
lists to make data entry simpler: 
 
• A lookup lists that displays values looked up from an existing table or query. 
• A value list that displays a fixed set of values that you enter when you create the 

field. 
 
The Lookup Wizard gives you the option to display the list as a combo box or a list 
box. The difference between these two types of boxes is in the way that the list of 
values is displayed to the user and whether it is possible to allow the user to add to the 
list of values. If you use the list from a table or query’s datasheet, the list can only be 
displayed as a combo box.  
 
The most common type of lookup list displays values looked up from a related table. 
For example, the SupplierID field in the Products table of the Northwind sample 
database. This list is created by looking up the SupplierID values in the Supplier table 
and displaying the corresponding Supplier names. Picking a value from a Lookup list 
sets the foreign key value in the current record (SupplierID in the Products table) to the 
primary key value of the corresponding record in the related table (SupplierID in the 
Supplier table). 
 
A value list looks the same as a lookup list, but consists of a fixed set of values you 
type in when you create it. A value list should only be used for values that will not  
change very often and don’t need to be stored in a table. For example, a list for a 
Salutation field may contain the following values, Mr, Mrs, and Ms. 
 
You can add a new lookup or value list field to a table in either design view or 
datasheet view. However, if the field you want to use as the foreign key for a Lookup 
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table already exists, you must open that field’s table in design view to define the 
Lookup field. 
 
To create a field that looks up and displays data from another table or a value 
list in design view 
 
1.  Open the table in Design view. 
 
2.  Insert the new field or if the field you want to use already exist, click in that field’s 

row. 
 
3.  In the data type column, select Lookup Wizard. 
 
4.  To display data from another table; select option (1) I want the lookup column to 

look up values in a table or query .To display data from a value list; select option (2) 
I will type in the values that I want. 

 
5.  Click Next and follow the instructions in the remaining Lookup Wizard dialog boxes. 
 
To create a field in datasheet view that looks up and displays data from another 
table or value list 
 
1. In Datasheet view, click on the column to the right of where you want to insert the 

field, and then on the Insert menu, click Lookup Column.  
 
2.  In the first dialog box described in part 4 above, select the option that indicates your 

choice. 
 
3.  Click Next and follow the instructions in the remaining Lookup Wizard dialog boxes. 
 
 
Activity P2-2 
 
Convert the certification (e.g. U, PG, 12, 15, 18) field of the Video table into a Lookup 
field that uses a value list, as shown in Figure P2-1.  
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Figure P2-1:  Value list for certification field of Video table. 
 
 
Activity P2-3 
 
Convert the directorNo field of the Video table into a Lookup field that displays data 
from another table, as shown in Figure P2-2. To start this activity it is necessary for 
you to first create a table called Director that will hold the details of directors.  
 
The Director table has the following fields (with the data type of each in brackets): 
directorNo (Text), directorName (text) 
The primary key is directorNo 
 
When converting the directorNo field to a Lookup field select the option that hides 
the key column (directorNo) and only display the directorName field in the Video 
table. 
 
 
  

 
 

Figure P2-2:  The directorNo field of the Video table displaying data from the 
Director table. 
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Resize Columns and Rows and Move Columns in a Datasheet 
 
In Datasheet  view,  you can resize columns and rows and move columns to fit your 
immediate needs, similar to the way you can edit a spreadsheet.  In addition, you can 
save your layout so that Microsoft Access always displays the datasheet the way you 
want it.  
 
To resize a column to fit the data it contains 
 
1.  Open the table in Datasheet view. 
 
2. Double-click an edge of the fields selector (column heading) of the column. 

Microsoft Access resizes the column to fit the data. 
 
To resize rows in a datasheet 
 
1. Position the pointer on the border of any record selector. The pointer changed to ⋅to 

show that the border can be moved up or down. 
 
2. Drag the border down to make all the rows taller.  Drag it up to make all the rows 

narrower. 
 
3. When the row is the size you want, release the mouse button.  Microsoft Access 

resizes all the rows. 
 
To reorder columns 
 
1. Position the pointer on the field selector (column heading) of the column to be 

reordered. The pointer changes to ↓ to show that you can select the column. 
 
2. Click the field selector to select the column. 
 
3. Click the field selector again, hold the mouse button down, and drag the column to 

the left or right, over the other column(s). 
 
4. When the pointer is where you want the column placed, release the mouse button. 

Microsoft Access reorders the columns. 
 
To save your datasheet layout 
 
On closing the datasheet window you can choose whether you wish to save the 
current layout of the datasheet.  
 
 
Activity P2-4 
 
View any of your tables in Datasheet form and practise editing the layout by resizing 
columns and rows, and by reordering the columns. Do not save your rearranged 
datasheet. 
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Print, Minimize, Restore, and Close a Table 
 
You use the same techniques to print, minimize, restore, and  close a table that you 
use in any standard application for Windows.  Use these techniques for any Microsoft 
Access object. 
 
To print a table 
 
With the table open in datasheet view, choose Print from the File menu (or click the 
Print button on the toolbar) and then choose OK. 

  
                        
To minimize a table 
 
Click the Minimize button    in the upper-right corner of the table window. Microsoft 
Access minimizes the table to an icon and places the icon at the bottom of the 
Microsoft Access window. This moves a table out of the way without closing it. 
 
To restore a table 
 
Double-click the table icon in the Microsoft Access window. 
 
To close a table 
 
From the File menu, choose Close. If you’ve made changes to the table design or 
layout since last saving it, Microsoft Access prompts you to save the changes.   
 
Activity P2-5 
 
Print the datasheet for your Video table.  Practise, minimizing, restoring and closing 
your tables. 
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Practical 3 
 
 
In this practical you will learn how to  create a customized form, how to use it to view 
data and add new records, and how to print it. You should first read the information 
given in this practical and then complete the activities listed throughout. 
 
 
Create a Form with a Form Wizard 
 
You can use a form to view and change your data in a layout other than the datasheet. 
In this section, we use a  Form Wizard to create a customized form and AutoForm to 
build simple forms automatically. Other Form Wizards provide a variety of layouts and 
styles for you to choose from.  They prompt you with questions about the form you 
want and then build the form based on your answers.  After using a Form Wizard to 
create your form, you can modify it if you want to. 
 
1. Open the database. In the Database window, click the Forms button. Microsoft 

Access displays the list of forms in the database. 
 
2. Choose the New button (or select Insert menu, and then choose Form). Microsoft 

Access displays the New Form dialog box. 
 
3. Click on the down-arrow to select the table or query to provide the data for the form. 
 
4.  Choose the Form Wizard option and then follow the instructions in the Form Wizard 

dialog boxes. 
 
Note: If  you select any of the AutoForm options, a form is automatically created and 
opened for  you. The form shows the first record in the selected table. 
 
 
Use a Form to View Records 
 
Now you have a form that you can use to view, change, add, and delete records in the 
selected table.  Examine the way Microsoft Access displays information on a form. The 
objects on the form are called controls which can be used to change the way you view 
your data.  
 
Microsoft Access places three kinds of controls on  a form. A form based on the Video 
table of the StayHome database created using the AutoForm (Columar) facility is 
shown in Figure P3-1.  
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Figure P3-1: Form based on Video table in Form view. 
 
 
A label displays text such as a title, caption, or message (e.g. Video). 
 
A text box provides an area where you can display or type text or numbers that are 
stored in your database.  Fields such as catalogNo and title of the Video table are 
displayed in text boxes. 
 
There are a variety of other controls you can add to Microsoft Access forms as well, 
including controls that display lists, contain pictures, or carry out actions.   
 
Microsoft Access forms provide two views of your data:  Form view and Datasheet 
view.  Form view is often the best way to see all the fields in a single record at the 
same time, without scrolling.  On the other hand, Datasheet view is a convenient way 
to view many records in your table at once.  You can use the toolbar to switch between 
the two views. 
 
To switch to Datasheet view 
 
From the View menu, choose Datasheet View (or click the arrow to the right of the 
View button on the toolbar and select Datasheet View).     
     
To switch to Form view 
 
From the View menu, choose Form View (or click the View button on the toolbar and 
select Form View).  
 
To move from record to record on a form 
 
Use the navigation buttons in the lower-left corner of the form’s window to go to the 
first, last, previous, or next record. You can also use the Go To command in the Edit 
menu to move to the first, last, or next record or to a new record. 
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Activity P3-1 
 
Open your StayHome database. Create a form for your Video table using the Form 
Wizard facility and name this form VideoForm1. Use the form to view records in your 
Video table. Practise changing between viewing your Video table using Form view and 
Datasheet view. 
 
 
 
 
Add and Save Records with a Form 
 
To add a new record 
 
1.  From the Edit menu, choose GoTo, and then choose New Record (or click the 

New button  at the bottom of the form and on the toolbar).   

            
     Microsoft Access displays the blank form at the end of the records.  
 

You can also use the Records menu and select Data Entry. However, in this mode 
you can only add and then view the newly appended records.  

 
2.  Enter data using TAB to move between fields. 
 
To save a record 
 
When you have completed the data entries for a record, press TAB to move to the 
next record. 
 
As soon as you leave the record, Microsoft Access saves it in the table. If you want to 
save a record without leaving it, choose the Save Record command from the Records 
menu. 
 
To undo your most recent change in a field before you leave the field 
 
From the Edit menu, choose Undo Current Field/Record  (or click the Undo Current 
Field/Record button on the toolbar).    

            
To delete a record 
From the Edit menu, select Delete Record or by clicking the Delete Record button.   

 
 
 
Activity P3-2 
 
Use your form to view, change, add and delete records in your Video table. Use the 
Undo Current Field/Record facility while editing your records. 
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Print, Save, and Close a Form 
 
You can use Print Preview to see how your form will look in print before you print it. 
 
To preview how a form and its data will look on a page 
 
1. Choose Print Preview from the File menu (or choose the Print Preview button on 

the toolbar). Microsoft Access displays your form and its data as it will look in print. 

             
 
2.  To zoom in on the page, position the pointer over the page so that it turns into a 

picture of a magnifying glass, and then click (or click the Zoom button on the 
toolbar). 

            
 
3. To return to a view of the entire page, click the form again (or click the Zoom button 

again). 
  
You can print your form from Print Preview or Form view. 
 
To print a form 

1. From the File menu, choose Print (or click the Print      button on the toolbar). 
Microsoft Access only displays the Print dialog box when you select to print using 
the menu options. 

 
To save a form 
 
1.  From the File menu, choose Save. When a form is saved for the first time, Microsoft 

Access displays the Save As dialog box. 
 
2. Enter  the name of the form and then choose OK. 
  
To save and rename a form, select the File menu and choose Save As. 
 
To close a form 
 
From the File menu, choose Close (or double-click the Control-menu box in the upper-
left corner of the Form window). 
 
 
Activity P3-3 
 
First preview, and then print VideoForm1.  
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Customizing Your Form 
 
In this section, you will learn how to place, move, and resize controls on forms and 
how to display values in a list.  In addition, you will learn how to show a default value in 
a control so that the field has that value automatically for each new record. 
 
Change a Form’s Design 
 
You change the appearance of a form in the form’s Design view.  You can open your 
form in Design view from the Database window. 
 
To open a form in Design view 
 
1. In the Database window, select the name of the form.  (if necessary, click the Forms 

button to display the list of forms) and then click the Design  button. Microsoft 
Access opens the form in Design view. 

 
Microsoft Access divides a form into five sections in Design view. A form based on the 
Videos table of the StayHome database is shown in Figure P3-2.  
 
The form header prints at the top of the first page (currently blank). When you are 
viewing data, the form header appears once at the top of the window. 
 
The page header prints at the top of every  page (currently blank). The page header 
only appears when printed or in print preview. 
 
The detail section contains the fields from the table.  When you are viewing data, the 
detail section is repeated for each record.  When you print the form, the detail section 
shows as many records as will fit on a page. 
 
The page footer prints at the bottom of every  page (currently blank). The page footer 
only appears when printed or in  print preview. 
The form footer prints at the bottom of every page (currently blank).  When you are 
viewing data, the footer appears once at the bottom of the window. 
 
All forms have a detail section, but not all forms have a form/page header and footer.  
To add these sections to a form, choose the Page Header/Footer command or Form 
Header/Footer from the View menu. 
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Figure P3-2:  Form based on Video table in Design View. 
 
 
Activity P3-4 
 
Examine VideoForm1 in Design view. Ensure that you understand the purpose of the 
different sections of the form. 
  
 
 
 
Select and Resize Controls 
 
Controls are the objects on your form that display data from a field or words in a title.  
In Design view, you can select, resize, move, and otherwise manipulate the controls on 
a form. 
 
To select a control 
 
Click the field’s text box.  (Make sure to click the text box and not its attached label.) 
When you select a control, Microsoft Access displays size and move handles around 
the control. 
 
Drag the handles on the top and bottom to size the text box vertically. 
Drag the handles on the left and right sides to size the text box horizontally. 
Drag the handles in the corners to size the text box both vertically and horizontally. 
In controls with attached labels, use the move handles to move each part separately. 
The size of the text box should be appropriate to the maximum length of the values to 
be displayed in the field. 
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To resize a control 
 
1. Position the pointer on the part of the border of the text box that is to be resized. 
2. Drag the border to shorten or lengthen the text box.  When the box is the size you 

want, release the mouse button. 
 
You can also select more than one control at a time.  This is a convenient method for 
moving or aligning a group of controls. 
 
To select more than one control 
 
Position the pointer beside (not on) one of the controls you want to select, and then 
drag diagonally through all the controls you want to select. While you drag, Microsoft 
Access draws a rectangle around the controls.  When you release the mouse button, 
all the controls in or touching the rectangle are selected.  (You can also select a group 
of controls by holding down the SHIFT key while you click each control.) 
 
Move Controls 
 
All the text box controls on your form have attached labels.  You can move a control 
and its attached label together, or you can move them separately.   
 
To move a control 
 
1. If a control is selected but is not the one you wish to select, click outside the control 

to cancel the selection. 
2. Position the pointer anywhere on the selected control, and hold down the mouse 

button. The pointer changes to a hand symbol. 
3. Drag the control so that it is next to its text box. Note that Microsoft Access moves 

the text box and its attached label together. 
4. When the control is positioned where you want it, release the mouse button. 
 
To lengthen a section 
 
1. Position the pointer on the border between the detail section and the form footer.   
2. Drag the border down to lengthen the section. 
 
Move Controls and Attached Labels Separately 
 
When you move a text box, its attached label moves with it.  You can also move a 
control or its attached label separately.  To do that, you use the move handles.  
 
To move the attached label separately 
 
1. Select the control. 
2. Position the pointer over the label’s move handle. When the pointer is over the 

handle, it changes to a pointing hand. 
3. Drag the move handle to the required position. 
4. When the label is where you want it, release the mouse button. 
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Add a Label and Edit Label Text 
 
A label is a type of control you can place on your form to add information. A 
freestanding label is not bound to a field (like a text box) or attached to a control (like a 
text box’s label). The first time you open a form in Design view, Microsoft Access 
displays the toolbox.  
 
You use the toolbox to place new controls on your form. You can close or open the 
toolbox by choosing Toolbox from the View menu.  You can also move the toolbox on 
your screen by dragging its title bar. 
 
More information  For details about each type of control, click the respective tool in 
the toolbox and press F1. 
 
To draw a freestanding label 

1. Click the Label tool in the toolbox.        
2. Click where you want to place the label. 
3.  Type in your label. As you type, Microsoft Access sizes the label to fit your text.  
 
To edit text in a label 
 
1. Click the label attached to a text box.  Microsoft Access selects the label. 
2. Click the label again. Microsoft Access places an insertion point in the text of the 

label. Now you can edit the text. 
 
Change the Appearance of Text 
 
Visual style in text can add important functional impact or aesthetic appeal to your 
form.   
 
To make text  italic 
 
1. Select the label. When you select a label or a control that includes text, the toolbar 

enables additional tools for changing the appearance of the text. 

2. Click the Italic button on the toolbar.       
 
2.  From the Format menu, choose Size, and then choose To Fit. Microsoft Access 

resizes the label to fit the new text. 
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To change the visual style of a control 
 
1.  Select the label and use the various options available through the visual style 

buttons on the toolbar.   
 

 
Fill/Back Color           Font/Fore Color Line/Border Color         Special Effects: Flat         
Line/Border Width 
 
An example of a customized form is shown in Figure P3-3. 
 

 

 
 
 
Figure P3-3:  Customized Form based on Video table in Form View. 
 

 
Activity P3-5 
 
Customize your VideoForm1 form to look like the form shown in Figure P3-3. Once 
you have made the required alterations, save your form as VideoForm2. 
 
 

 
Now continue to experiment with different fonts, sizes, colours, and alignments for the 
text.  Use the buttons on the toolbar or the options in the palette to make your 
changes. If you want to save this version of your form, use the File menu and choose 
Save As to give this form another name, otherwise, close the form without saving. 
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Display Values using a Combo Box 
 
The controls that you use to enter, update, and display data from a table or query are 
bound to fields in the table or query.  
 
For some controls it is useful to use a combo box that shows appropriate values for 
the control and if necessary the values can be displayed with  descriptive text that 
informs the user  about the different values. The user simply makes a selection from a 
list of possible entries. This helps the user to enter the correct values for a given 
control.  You can replace a control with a combo box by first deleting the control and 
then using the Combo Box Wizard to create the new combo box control. 
 
To delete a control 
 
1. Click on the text box to select it. 
 
2. Press the DEL key. Microsoft Access deletes the text box and its label. Note that to 

delete a label without deleting the text box, select the label and press the DEL key. 
 
When you add a bound control to a form, your first step is to select the tool from the 
toolbox for the type of control you want. 
 
To add a combo box control to a form 
 

1. Click the Combo Box tool in the toolbox.      
     

2. Click the form where you want to draw the combo box. Microsoft Access displays 
the first Combo Box Wizard dialog box. 

 
3. Follow the instructions in the Control Wizard dialog boxes. 
 
4. Click the Finish button to create the combo box control. 
 
Switch to Form view to see the combo box control.  
 
If you selected to type in the values to be displayed by the combo box, you must now 
defined these values using the property sheet for the combo box, which is described in 
the following section. 
 
Set Control, Section, or Form Properties 
 
Each control on a form has a set of properties.  Properties determine a control’s 
appearance and behaviour.  For example, when you give your freestanding label, italic 
lettering and a three-dimensional look, you were setting properties for the label.  To 
see and set control properties, you open the property sheet.  The property sheet 
shows the properties of the selected object. A form and each of the sections and 
controls it contains has its own set of properties.  
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To display the property sheet 

From the View menu, choose Properties (or click the Properties      button on 
the toolbar).  
 
To see the properties of an object 
 
With the property sheet open, click on a control. Microsoft Access displays the 
properties of the selected control in the property sheet.  You can leave the property 
sheet open while you work on your form. 
 
Display a Description in the Status Bar 
 
In Form view, the status bar displays the descriptions you entered for each field when 
you originally create a table.  Because the combo box is a new control, it does not 
have a description to display.  You can define a description by setting the Status Bar 
Text property for the combo box. We noted earlier that, when the combo box is 
created, the Combo Box Wizard sets the properties of the new control. 
 
The Row Source Type property tells Microsoft Access what type of source provides 
the values in the list: a table or query, a list of values you provide, or a list of fields. 
 
The Row Source property identifies the source of the list.  For example, if the Row  
Source Type property is set to Table/Query, you set the Row Source property to the 
name of the table or query that contains the values for the list. 
 
The Column Count property determines how many columns are in the combo box. 
 
The Column Widths property determines the width of the columns. 
 
To set the Row Source property 
 
1. While viewing the properties of the control, select the Row Source property box. 
2.  In the Row Source property box, type in the source of the values, e.g. table name, 

query name or enter a list of values, where each value is separated  by a semi-
colon. 

 
To set the Status Bar Text property 
 
1. While viewing the properties of the control, select the Status Bar Text property box. 
2.  In the Status Bar Text property box, type in the description.  
 
Activity P3-6 
 
Open the property sheet for your form and examine the properties for the different 
objects on your form.  
 
In Practical 2, you created a combo box control for the certification field of your Video 
table during the design of the table. In this practical, create a combo box control for the 
category field of your VideoForm1 form  
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The Row Source for the combo box for the category field should contain the following 
values: Action; Adults; Children; Comedy; Drama; Horror. 
 
Now, save your form and look at it in Form view. Add a new record to your Video table 
using your form.  
 
 
 
Make Your Form Work for You 
 
When you create a form that you or someone else will use to add, change, or view 
records, think about how you might want that form to work for you.  For example, to 
automatically enter new values for each new record, to display error messages, or to 
show the results of calculations in some controls. 
 
Setting a Default Value 
 
In some cases, one value might show up in a field more often than any other.  For 
example, we may assume that ‘PG’ is the most common certification for videos in the 
shop. When you add a new video, you can have Microsoft Access automatically fill in 
the certificate field with ‘PG’.  We set the Default Value property for the control to ‘PG’. 
You can also set the Default value of a field when you design your table.  Then 
Microsoft Access will automatically apply that value to any control you create that is 
bound to the field. 
 
Showing Calculations 
 
A control that is bound to a field in a table or query displays data from the field.  You 
can also use a control to display data that is not in your tables.  For example, you 
might want to display the current date in a text box on the Video form.  The text box 
would not be bound to any field; instead, it would display the result of this expression:  
=Date().  The Date function returns the current date as reported by the system clock in 
your computer.  A control that displays the result of an expression is called a calculated 
control. 
 
To create a calculated control, select the tool in the toolbox for the control you want, 
and then click your form where you want the control to appear.  Microsoft Access 
creates the unbound control.  Now type the expression that you want in the control, or 
set the control’s Control Source property to the expression. 
 
Creating Validation Rules 
 
Validation rules help you ensure that information entered into a form is correct before 
Microsoft Access stores it in your tables.  For example, the StayHome video shop 
opened on 1st September 1985 and therefore the dateJoined field for the Member 
table cannot take a value that is before this date. If we attempt to enter a date that is 
wrong, we want  Microsoft Access to stop errors like this and display a message that 
helps the user fix the problem.  Just as you use expressions to show calculations on a 
form, you can also use expressions to set rules for validating data. To create the rule, 

 
 



©200, .Ibrahim I. Hamarash, MS-Access Lab Manual, Database Systems, Dept. of Software Eng., Erbil.       
 
 

33

set the Validation Rule property of the dateJoined  control to the following expression: 
>=#1/09/85#. 
 
Set the Validation Text  property to a message that you want Microsoft Access to 
display if the date entered in the text box falls out with the defined range. 
 
You can also set a validation rule for a field when you design your table. Then 
Microsoft  Access will apply that validation rule automatically to any control you create 
that is bound to the field.  If necessary, you can set a separate, more restrictive 
validation rule for that control on the form. 
 
Activity P3-7 
 
Set default values for the certificate and category controls of your VideosForm1 form. 
Assume that the majority of videos in the shop are of certificate (PG) and category 
(Action).  
 
Add a control to this form to display today’s date in the top-right hand corner. 
 
Set a validation rule for the dailyRental control such that no value entered into this field 
can be less than 2.00. Also add appropriate validation text.  
 
Now, save your form and look at it in View form. Add a new record to your Video table 
using your form.  
 
 
 
Activity P3-8 
 
Create customized forms for your Member, VideoForRent and RentalAgreement 
tables. Change the appearance of each form, add combo boxes, default values, 
calculated fields and validation rules, where appropriate. 
 
Now, save your forms and look at them in View form. Add new records to your 
Member, VideoForRent and RentalAgreement tables using your forms.  
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Practical 4 
 
 
In this practical you will learn how to create a query that associates related data from 
different tables together in the same datasheet. You should first read the information 
given in this practical and then complete the activities listed throughout. 
 
To undertake the activities in this practical you need to have all of the tables of the 
StayHome database built with records. If you do not have a complete StayHome 
database, please take a copy of this database from your class directory on the 
network.  
 
 
Create a Query 
 
To bring together the data that we need from the one or more tables, we need to 
create a select query.  A select query retrieves a set of records that match the 
specified criteria. As with other types of objects in an Access database, there are 
numerous ways to create queries. 
 
To create a select query 
 
1. Start Microsoft Access, and open the required database. 
 
2. In the Database window, click the Queries button. 
 
3. Choose the New button. Microsoft Access displays the New Query dialog box as 

shown in Figure P4-1. 
 
 

 
 
 

Figure P4-1 The New Query dialog box. 
 
 
4. If you want to design the new query, select Design View and click OK. (If you 

want a wizard to help you build the query, select one of the other options).  
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5. Microsoft Access opens the Select Query window and displays the Show Table 

dialog box so that you can select the tables to use for your query as shown in 
Figure P4-2. 

 
 

 
 
 
Figure P4-2: The Select Query window and Show Table dialog box. 
 
 
6. Select the first table, and then choose the Add button.  Microsoft Access adds 

the table to your query. Select the next table(s), followed by the Add button in 
each case. For example, in the Figure P4-2 all of the tables in the StayHome 
database have been selected for this query. 

 
7. Choose the Close button. 
 
The Select Query window 
 
A query is a question you ask about the data in your database. To create a query, 
you specify the fields and records you want to see in the Select Query window. The 
Select Query window is a graphical query-by-example (QBE) tool.  Because of its 
graphical features, you can use a mouse to select, drag, and otherwise manipulate 
objects in the window to define an example of the records you want to see. You  
specify the fields and records you want to include in the query in the OBE grid. 
 
The Select Query window displaying the Member, RentalAgreement, VideoForRent, 
Video and Director tables is shown in Figure P4-2.  
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Join  Tables 
 
If  Microsoft Access has not joined your tables automatically or if you  have not 
created a relationship between the tables yourself, the tables will not be connected 
by join lines in the Select Query window.  However, you can still use related data 
from the two tables, by joining the tables in the Select Query window when you 
create the query. 
 
Before you can join two tables in a query, the related fields must be present in both 
tables.  For the join to work, the two fields must contain matching data in related 
records. 
 
To draw a join line 
 
Select the field to be used in the join and then drag the field from its table to the 
same field in the table to be joined. When you draw a join line between two tables in 
the Query window, the join applies to that query only.  If you use the same two tables 
in another query, you will need to join them again. 
 
Note join lines have properties you can set and change.  To see the properties of a 
join line, double-click the line (or click the line and choose Join Properties from the 
View menu).  
 
To delete a join line 
 
Click the join line to select it, and then press the DEL key. 
 
Microsoft Access deletes the join.  This does not change the data in your tables, but 
if you create a query now that includes fields from both tables, you might be 
surprised at the result.  When it cannot determine how to associate the data, 
Microsoft Access creates a record for every possible combination of data between 
the tables. 
 
 For more information about join properties, press F1 from the Join Properties dialog 
box. 
 
Activity P4-1 
 
Using the Select Query window, select your Member, RentalAgreement, 
VideoForRent, Video and Director tables (as shown in Figure P4-2). Practise joining 
and deleting the join lines between your tables. Examine the join properties of the 
join lines relating your tables. 
 
Note that, in the Query window, Microsoft Access displays a table’s primary key field 
or fields in bold.  For example, the memberNo field in the Member table is in bold. 
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It is a good idea to create relationships between your tables, because in many case 
Microsoft Access can join the tables in a query automatically.  
 
Creating Relationships between Tables 
 
You relate tables or queries by specifying one or more fields that contain the same 
value in related records.  These matching fields often have the same name in each 
table.  In many cases, you will want to relate the primary key of one table to a 
matching field in another table. You create, view, and edit relationships in the 
Relationships window. 
 
When you first create a table, it is not related to any other table.  To create a 
relationship, you start by opening the Relationships window and add the tables or 
queries you want to relate and then you define the relationship(s). 
 
To display the Relationships window 
 
In the Database window, choose Relationships from the Tools menu (or click the 
Relationships button on the toolbar). 

  
 
If  you have viewed or edited relationships before, the Relationships window appears 
as you last saved it.  If you are editing relationships for the first time in this database, 
the window is empty and Microsoft Access displays the Show Table dialog box. 
 
To add tables or queries to the Relationships window 
 
1.  If the Show Table dialog box is not automatically displayed, choose Show Table 

from the Relationships menu (or click the Show Table button). 

 
 
2. Select the table or query you want to create a relationship for, and then choose 

the Add button.  To select more than one table or query at a time, hold down the 
CTRL key and click each you want to add.  To select all or a block of tables and 
queries, click the first table or query, then hold down the SHIFT key and click the 
last one. 

 
To create a relationship 
 
1. Drag the field(s) that you want to relate from the field list of a table or query to the 

matching field in another table or query.  The field you drag belongs to the 
primary table; the matching field where you drop it belongs to the related table. 

 
2. Microsoft Access displays the Relationships dialog box.  Check the field names 

displayed in the two columns and edit them if necessary.  Choose OK. 
 
Microsoft Access creates the relationship and displays a line between matching 
fields in the two tables.  The relationship remains in your database until you delete it. 
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Activity P4-2 
 
Create relationships between your Member, RentalAgreement, VideoForRent, Video 
and Director tables using the Relationship window. 
 
 
 
 
Select Fields 
 
Now that you have the table(s) you want for your query, you are ready to define the 
records you want.  Start by selecting the fields from each table that you want to see 
in the answer.  
 
To add fields to a query 
 
1.  Drag the field from the table field list to the first cell in the Field row of the QBE 

grid. 
 
2.  When the pointer is over the cell, release the mouse button. 
 
3.  Repeat for all of the required fields. 
 
The check boxes in the Show cells for those fields are ticked, which shows that the 
data in the fields will be displayed in the query’s datasheet. 
 
The Query window displaying a query that retrieves the memberNo, fName, lName 
and DOB fields of the Member table is shown in Figure P4-3.  
 

 
 
 

Figure P4-3: Creating a query on the Member table. 
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To see the results of a query 

From the View menu, choose Datasheet View (or click the View button      on 

the toolbar). You can also click the Run button.   
 
For example, running the query shown in Figure P4-3 produces the datasheet shown 
in Figure P4-4. 
 

 
 
 
Figure P4-4: The datasheet produced when the query shown in Figure P4-3 is 

run. 
 
When you attempt to close the window displaying the results of a new or changed 
query, you will be asked if you wish to save the query. If required, you may save and 
rename the query at this stage. Microsoft Access provides a default name for each 
new query created, for example Query1. 
 
You may also save your query when you are creating it using the Select Query 
window. 
 
 
Activity P4-3 
 
In your Select Query window, create and run the following queries: 
 
(a)  From the Member table show only the memberNo, fName, lName and DOB 

fields (as shown in Figures P4-3 and P4-4).  
(b)  From the Member and RentalAgreement tables show only the fName, lName, 

rentalNo, dateOut and dateReturn fields. 
(c)   From the Member, RentalAgreement and VideoForRent tables show only the 

memberNo, fName, lName, rentalNo, videoNo, available and catalogNo fields. 
(d)   From the Member, RentalAgreement, VideoForRent and Video tables show only 

the memberNo, lName, videoNo, title and certificate fields. 
(e)  From the Video table show only the catalogNo, title, dailyRental and price fields. 
(f)  From the Video and Director tables show only the catalogNo, title, directorNo 

and  directorName fields. 
 
Create any other useful queries on your tables. 
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Specify Criteria 
 
The answer to a query is an updateable set of records, which is called a dynaset.  
When you use a query to access data, its dynaset consists of the current data from 
the tables where the data is stored. If  you change data in a dynaset, Microsoft 
Access updates the data in the underlying tables. 
 
You can use queries and dynasets in the same way  that you use tables to access 
data.  For example, you can base a form or report on a query that displays data from 
two or more tables.  Because the data in the dynaset is always current, you know 
that the data you are viewing on the form or report reflects the latest changes in your 
database.  Any changes that you make to the data using the form are saved. 
 
A dynaset may include all records in a table or you can specify the records you want 
to see using  criteria.  You use values in fields to indicate the records you want to 
see. 
 
To specify criteria for a query 
 
1. To return to Design view, choose Design View from the View menu or click the 

View button on the toolbar. 
 
2. In the lower portion of the Design window, move to the Criteria cell(s) of the 

required table(s) and enter the required value(s). 
 
3. To see your dynaset, choose Datasheet View from the View menu or click the 

View button on the toolbar. 
 
Microsoft Access limits the dynaset to the records that match your criteria. 
 
 
Specify Additional Criteria 
 
By adding and combining criteria in the Query window, you can create powerful 
queries that meet a variety of precise conditions. 
 
To add criteria to a query 
 
1. Switch your query to Design view.  
 
2. In the target column, enter the search criteria (phrase or expression) in the 

Criteria cell below the column heading, and then press ENTER. 
 
Microsoft Access evaluates the expression and then looks in the field for values that 
match the result of the expression.  Microsoft Access includes all the records with 
matching values in the field. 
 
Common types of search criteria include:  
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• The value in a field is equal to the value you specify, e.g. to search for the video 
with the title Natural Born Killers. Enter Independence Day in the title field of the 
Video table. 

 
• The value falls within a range of values, e.g. to search for all videos that have a 

daily rental rate less than £3.00. Enter <4.00 in the dailyRental field of the Video 
table. 

 
• The value begins with the value you set, e.g. to search for all members with a last 

name beginning with the letter M. Use the * wildcard and enter M* in the lName 
field of the Member table. 

 
For more information about expressions in Microsoft Access, choose Search from 
the Help menu and search for ‘expressions: examples.’ 
 
 
Activity P4-4 
 
In your Query window, create and run the following queries: 
 
(a) Locate a specific member given their first and last name. Show only the 

memberNo, fName, lName and address fields. 
(b) For a specific member, given their first and last name, show the details of his or 

her video rentals.  
(c) For a specific video, given the video title, show the first and last names and full 

addresses of those members who have rented this video. 
(d) Locate the first and last names of female members who joined the video shop 

after the 1st September 1994. 
(e) Locate the video number and title of videos in the Children category that have a 

daily rental rate of  less than £4.00 and are available for rent. 
(f) Locate videos that have ‘the’ in the title. 
(g) Locate the number, first and last names and addresses of those members who 

have rented videos this year. 
(h) Locate the videos directed by Sally Nichols. 
 
Practise creating and running any other queries on your tables.  
 
 
 
Sort Records 
 
You have the set of records you want, but you may want to see them sorted in a 
different order. Just as you can sort records in a table or form, you can sort records 
in a query by one or more fields. 
 
To sort records in ascending or descending  order 
 
1.   Switch to Design view. 
 
2. Click the Sort cell for the field (or use the arrow keys to move to the Sort cell). 
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3. Select Ascending, Descending or (not sorted) from the Sort list. 
 
4. Switch to Datasheet view to see the sorted records. 
 
 
Modify a Query 
 
The Query window is designed so that it can be easily modified.  
 
 To move a column in a query 
 
1. In Design view, click the field selector (column heading) of the column you want 

to         move. 
 
2. Click the field selector again, hold down the mouse button, and drag the column 

to its new location. 
 
To insert a column in a query 
 
1. Select the column to the right of where you want the new column inserted. 
 
2. From the Insert menu, choose Columns.  Microsoft Access inserts a blank 

column. 
 
To make a column wider or narrower 
 
Drag the right border of the field selector. 
 
To adjust a column’s width for the best fit 
 
Double-click the right border of the field selector. Microsoft Access adjusts the 
column width to accommodate the longest cell entry in the column. 
  
You can also include a field in your query without having it appear in the datasheet.  
This is convenient if you want to use the field to specify criteria for the dynaset but 
don’t want the field in your datasheet. 
 
To exclude a field from the query’s datasheet 
 
Clear the field’s Show box by clicking it. 
 
 
 
Activity P4-5 
 
Sort the records in your tables as follows: 
 
(a) List your video records in video title order. 
(b) List your video records in category order and then according to video title. 
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(c) List your videos in daily rental order, (most expensive at the top). 
(d) List your members according to last name. 
(e) List your members according to their sex and then in date of birth order 

(youngest at  
the top).  

 
Explore how to modify the layout of your query by deleting and inserting columns, 
changing the width of columns etc. 
 
 
 
 
Calculations 
 
Often, the most interesting information is a total, average, or some other type of  
calculation based on a set of records.  For example, the average age of all members 
of the video shop. 
 
To perform calculations in your query 
1.  From the View menu, choose Totals or click the Totals button on the toolbar.

  
 
Microsoft Access displays the Total row in the QBE grid. Note that Microsoft Access 
automatically fills in each box with ‘Group By’. 
 
2.  Select the Totals row and click on the arrow to choose the type of calculation you 

want performed on your records. 
 
 
Activity P4-6 
 
Create queries to answer the following questions. 
 
(a) What is the total price for all videos in your shop? (Hint: Select Sum for the Total 

row of the price field.) 
(b) What is the average daily rental rate for all of the videos in your shop? 
(c) What is the total price of videos in each category of video? 
(d) What is the total number of female and male members of your video shop? 
(e) What is the minimum and maximum daily rental rate for all videos in your shop? 
(f) For each member, list the total number of video rentals. 
(g) For each video, list the total number of rentals. 

 
 

 
 



©200, .Ibrahim I. Hamarash, MS-Access Lab Manual, Database Systems, Dept. of Software Eng., Erbil       
 
 

44

 

 

Practical 5 
 
 
 
In this practical, you will learn how to find a specific value in a set of records. In 
addition, you will learn how to use filters to interactively refine the set of records you 
are viewing. You will also learn how to create a subform that shows the set of 
records associated with a single record on the main form. You will also learn how to 
combine data from different tables into a single form by basing the form on a query. 
 
You should first read the information in this practical and then complete the activities 
listed throughout. 
 
 
Find a  value 
 
When you are looking for a specific value such as ‘Independence Day’ in the title 
field of the Video table, the Find command on the Edit menu of a form or datasheet 
provides the quickest way to find the record you want. 
 
You can tell Microsoft Access the exact value you want to find, or you can use these 
wildcard characters: the question mark (?), asterisk (*), or number sign (#).  For 
example, you can use L?s to find Los, Las, or L6s; you can use L*s to find Los or 
Louis; or you can use A#X to find A2X or A9X. 
 
To find a value 
 
1.  Open your datasheet and move to the required column. 
2.  From the Edit menu, choose Find (or click the Find button on the toolbar).  

 
 
     Microsoft Access displays the Find and Replace dialog box, as shown in Figure 
P5-1. 
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Figure P5-1: The Find and Replace dialog box. 
 
 
3.  Type the value you want to find in the Find What box. 
 
4.  Then select the other options as required by your search. 

 
5.  To find the first (and subsequent) occurrence of the value being searched for, 

choose the Find Next button. 
 
6.  When the search is completed, choose the Close button to close the Find and 

Replace dialog box. 
 
 
Activity P5-1 
 
Use the Find and Replace dialog box to locate specific records in your Member and 
Video tables. For example, find the following records: 
 
(a) Find female members of the video shop. 
(b) Find members who have a surname beginning with the letter ‘P’. 
(c) Find members who live in a certain area of Glasgow, e.g. G3. 
(d) Find videos with the ‘PG’ certification. 
(e) Find videos that are in the ‘Action’ category. 
(f) Find videos that have ‘The’ in the title. 
 
Undertake other searches to explore the options offered in the Find and Replace 
dialog box. Ensure that you understand how to use the wildcard characters. 
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Sort Records 
 
To sort records 
 
1.  Open your datasheet and move to the required column. 

2.  Click the Sort Ascending    button or the Sort Descending    button 
on the toolbar. You can also sort records by selecting Sort from the Records 
menu and by choosing Sort Ascending or Sort Descending. 

 
3.  The records are displayed in ascending or descending order using the values in 

the selected column. 
 
 
Activity P5-2 
 
Sort your members and videos records into the following orders:  
 
(a)   Sort your members records according to their last name. 
(b)  Sort your members records according to the date they joined the video shop with 

the   latest to join at the top of the list. 
(c)   Sort your members records according to their postal code. 
(d)   Sort your videos records according to the video title in descending order. 
(e)   Sort your video records into category order in descending order. 
 
 
 
 
Create a  Filter 
 
When you create a filter, you give Microsoft Access a set of criteria that describe the 
records you want to see.  Microsoft Access uses these criteria to select the records 
you want from the table or dynaset. There are four methods you can use to filter 
records: Filter by Form, Filter by Selection, Filter Excluding Selection and Advanced 
Filter/Sort. The method you pick depends on the criteria you want the records to 
meet and how you want the records sorted (if at all). 
 
Filter by Form and Filter by Selection are the easiest way to filter records. If you can 
easily find and select an instance of the value you want the filtered records to contain 
use Filter by Selection; otherwise use Filter by Form. You can save these filters as 
queries. For more complex filters, use Advanced Filter/Sort. 
 
To use Filter by Selection / Filter Excluding Selection 
 
1.  In a field on a form, subform or datasheet, find one instance of the value you want 

the records to contain. 
 
2.  Select the value, and then access the Records menu and choose Filter and then 

Filter by Selection or click the Filter by Selection button on the toolbar.  
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3.  To further limit the set of records, select another value, and then click the Filter by 

Selection button again. Repeat steps 2 and 3 until you have the records you want. 
 
You can use Filter Excluding Selection in exactly the same way that you apply  
Filter by Selection with the exception that you enter values that you do not want the 
records to contain. 
 
To use Filter by Form 
 
1.  In Datasheet or Form view, select the Records menu and then Filter and choose 

Filter by Form to switch to the Filter by Form window or click the Filter by Form 
button on the toolbar. 

     
 

2.  Click the field in which you want to specify the criteria that records must meet to 
be included in the filtered set of records. 

 
3.  Enter your criteria by selecting the value you are searching for from the list in the 

field, or by typing the value into the field.  
 

Note that you can find records which contain a  particular field that is empty or not 
empty by typing Is Null or Is Not Null into the field. You can also find records by 
typing a criteria expression into a field. For examples of criteria expressions – 
search the online help for Filters and then Examples of criteria expressions for 
queries and filters.  

 
4.  To specify alternative values that records can have to be included in the filters 

results, click the Or tab at the bottom of the window. 
 
5.  From the Filter menu and select Apply Filter/ Sort or click the Apply filter button 

on the toolbar.          
           

    
 
6.  To cancel the filter, from the Records menu, select Remove Filter/Sort or click 

on the Remove Filter button, which is a sunken version of the above button. 
 
To use the Advanced Filter/Sort  
 
1.  In Datasheet or Form view, from the Records menu, choose Filter and then 

Advanced Filter/Sort. 
 

Microsoft Access opens the Filter window as show in Figure P5-2, where you define 
the records you want to see. 
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Figure P5-2:  The Filter Window. 
 
 
The Filter window looks a lot like a Query window.  However, in the Filter window,  
you cannot add tables or compute values the way you can with a query,  you can 
only specify criteria and sort order. 
 
2.  Add to the design grid the field or fields you will need to specify the values or other 

criteria the filter will  use to find the records. 
 
3.  Type in the value in the Criteria cell for the appropriate field, and then press 

ENTER. Also, select the sort order in the Sort cell of the appropriate field(s), if 
required. 

 
4.  Apply the filter by accessing the  Filter menu and selecting Apply Filter/ Sort or 

click the Apply filter button on the toolbar.  
        
5.  To cancel the filter, from the Records menu, select Remove Filter/Sort or click 

on the Remove Filter button.        
    

 
Activity P5-3 
 
Examine the four methods of creating a filter.  
 
Apply filters to your members and videos records. For example, create the following 
filters to view: 
 
(a) Only male members of the video shop (as shown in Figure P5-2). 
(b) Only male members of the shop who joined the shop this year in order of last 

name and then first name. 
(c) All members born in the 1960s. 
(d) Only videos in the Children category with a daily rental rate of less than £4.00 

and sorted according to video title. 
(e) Only videos currently available for rent with a certification of  ‘PG’ or ‘U’. 
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(f) Only videos by a certain director. 
(g) Only members of the video shop that have not supplied a date of birth. 
 
Filters can also be used with queries. Create other useful filters on your queries. 
 
 

 
 
Create a Form That Contains a Subform 
 
We can create a form that is actually two forms in one. Such a form is made up of a 
mainform and subform. The mainform displays one record at a time (e.g. details of 
a member) and at the same time, the subform displays the many records associated 
with that record (e.g. all of the video rental details for a member).  This type of data is 
said to have a ‘one-to-many’ relationship; one member has many video rentals. 
 
A form with a subform has advantages over a query for viewing this type of data.  
Because a query displays its result in a datasheet, each field on the ‘one’ side of the 
relationship must be repeated for each record on the ‘many’ side.  But a form with a 
subform can show the data on the ‘one’ side of the one-to-many relationship once at 
the top of the form and show all the records on the ‘many’ side of the relationship 
grouped below it. 
 
 
To create a form that contains a subform 
 
1. In the Database window, click the Form button. 
 
2. Choose the New button. 
 
3. Select the table on the ‘one’ side of the relationship from the list of tables and 

queries. 
 
4. Select the Form Wizards option and click the OK button. 
 
5.  Select the fields for the main form. 
 
6. In the Tables/Queries box, select the table on the ‘many’ side of the relationship 

as the source for the subform. Select the required fields and click the Next button. 
 
7. Select the Form with subform(s) option and click the Next button. 
 
8.  Complete the instructions in the following Forms Wizard dialog boxes.  
 
The Form Wizard creates your form and opens it for you as shown in Figure P5-3. 
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Figure P5-3: A main form called Member that contains a subform called 
RentalAgreement. 

 
 
Activity P5-4 
 
Create the following forms that contains a subform to display the following 
information: 
 
(a)  Member details including the memberNo, fName, lName and the details of videos 

rented for a member including the rentalNo, videoNo, dateOut and dateReturn 
fields (as shown in Figure P5-3). 

 
(b)  Video details including the catalogNo, title, certification and category fields and 

the details of copies for a video including the videoNo and available fields. 
 
Create other forms with a subform to display a different selection of fields from your 
Member, RentalAgreement, VideoForRent, Video and Director tables. Attempt to 
improve the appearance of your forms. 
 
 
 
 
Use a Query to Include Fields from More Than One Table 
 
Suppose that you want to review your video rental details one by one. It is 
sometimes easier to use a form rather than a datasheet because a form has a more 
convenient layout for viewing individual records.  Also, it would be convenient to 
have the member’s number and name appear on the form along with the rental 
details. In this case, you don’t need to group the data from either table.  You just 
need to combine data from different tables in the same record on a form.  To do that, 
you create a query that includes the fields you want and then base the form on the 
query. 
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To create a query 
 
1.  From the Database window, create a new query. 
 
2.  Add the required tables to the query, and then close the Show Table dialog box. 
 
3.  From the tables, drag the required fields to the Field row of the QBE grid. 
 
4.  Save and name the query. 
 
5.  Close the query. 
 
To base a form on a query 
 
I . In the Database window, select to create a new form. 
 
2.  Select the multi-table query and then follow the same instruction as when you 

create a form base on table using the Form Wizard or AutoForm options.  
    
Microsoft Access creates a form based on the query. Now you have a form that 
shows data from more than one table in the same record.   
 
To Create a Form based on an Autolookup Query 
 
We can design a multiple-table query to automatically fill in certain field values for a 
new record. When we enter a value in the join field in the query or in a form based 
on the query, Microsoft Access looks up and fills in existing information related to 
that value. For example, if we know the value in the join field between the 
RentalAgreement table and the Member table we could enter the memberNo and 
have Microsoft Access enter the rest of the information for that member. If no 
matching information is found, Microsoft Access will display an error message. 
 
To create an autolookup query, we add two tables that have a one-to-many 
relationship and select fields for the query to the QBE grid. The join field must be 
selected from the ‘many’ side of the one-to-many relationship. For example, in a 
query that includes the RentalAgreement and Member tables, we drag to the design 
grid the memberNo field (foreign key) from the RentalAgreement table as shown in 
Figure P5-4. 
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When member number is selected. 

The member’s details are 
automatically filled in. 

 
 
Figure P5-4: Form based on a lookup query. 
 
 
 
ActivityP5-5 
 
Create the following autolookup forms: 
 
(a)  A form to accept video rental details including the rentalNo, videoNo, dateOut, 

dateReturn and memberNo. When the memberNo field is filled out, the 
corresponding member details in the fName, lName and address fields should be 
automatically filled in (as shown in figure P5-4). 

 
(b)  A form to accept video rental details including the rentalNo, memberNo, dateOut, 

dateReturn and videoNo. When the videoNo field is filled in, the corresponding 
video details including in the title, certificate, category and dailyRental fields 
should be automatically filled in. 
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Practical 6 
 
 
 
In this practical, you will learn how to create reports that groups data.  You will also 
learn how to create a customized database application, which includes creating a 
startup form and automating repetitive tasks using macros and the Command Button 
Wizard. You should first read the information given in this practical and then 
complete the activities listed throughout. 
 
 
How to Use Reports to Present Data 
 
You can use a report to present your data in print.  With a report, you have greater 
flexibility to present summary information than with a form.  For instance, you can 
include totals across an entire set of records in a report.  
 
To create a report with grouped data 
 
1. In the Database window, click the Reports button. 
 
2. Choose the New button. Microsoft Access displays the New Report dialog box. 
 
3. Select the required table or query from the list for the report. 
 
4. Select the Report Wizard button and click OK. Microsoft Access displays the first 

Report Wizard dialog box. 
 
5. Make these choices as you go through the dialog boxes: 
 

(a) Select the required fields from the table or query for the report. Click the Next 
button. 

(b) Select the field(s) to be used to group the records by. 
(c) Click on the Grouping Options button and select the option  ‘Normal’, which 

groups records together with the same value. Click OK and then the Next 
button. 

(d) If required, select the field(s) to sort records within a group of records. 
(e) If required, click the Summary Options button to set summaries (Sum, Avg, 

Min, Max) for your report. Click the Next button. 
 
6.  Complete the instructions for the final Report Wizard dialog boxes that set the 

style of the report. 
 
Microsoft Access creates and displays the report in Design View or in Print Preview, 
as shown in Figure P6-1.  
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Figure P6-1:  Report based on some fields of the Video table in Print Preview. 

 
 
Preview, Print, and Save a Report 
 
In Print Preview, Microsoft Access displays your report as it would appear in print. 
 
To see a whole page of the report 
 
1.  In Print Preview, position the pointer over the report.  The pointer changes to a 

magnifying glass. 
 
2.  Click the report. Microsoft Access displays a view of the whole page.   
 
3.  To zoom back in and view the data, click the report again. You can also use the 

Zoom button on the toolbar to zoom in or out of your report.  
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To close the Print Preview window 
 
Click the Close button on the toolbar. 
 
To print a report 
1.  From the File menu, choose Print or click the Print button on the toolbar. 

  
 
2.  Change the print settings if you need to, and then choose OK. Microsoft Access 

prints your report. 
 
To save a report 
1.  From the File menu, choose Save or click the Save button on the toolbar. 

  
 
2.  Microsoft Access displays the Save As dialog box. Give the report a name and 

choose OK. 
     
A Report in Design View 
 
You use Design view to modify the design of your report.  
 
To open a report in Design view 
 
1.  In the Database window, click the Reports button to display the list of reports. 
 
2.  Choose the Design button. Microsoft Access displays the report in Design view. 
 
Microsoft Access divides a report into sections.  In Design view, each section of the 
report appears once, as displayed in Figure P6-2.  

 
 

Figure P6-2: Report based on some fields of the Video table in Design View. 
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When you print the report, sections are repeated, as appropriate, until all the data in 
the report is printed.  The controls in each section tell Microsoft Access what data to 
print in the section. The Report Header prints at the beginning of the report. The 
Page Header and Footer  prints on every page. The Category Header and Footer 
prints for each category.  The Details section prints for each record in the category. 
 
 
Activity P6-1 
 
(a) Create a report for your Video table containing the catalogNo, title, category and 

certificate fields. Group your records according to the values in the category field 
and then sort on the values in the title field. (Note that this report is shown in 
Print Preview in Figure P6-1 and in Design view in Figure P6-2.) 

 
(b) Create a report for your Video table containing the category, dailyRental and 

price fields. Group your records according to the values in the category field and 
then sum the values in the dailyRental and price fields.  

 
(c)  Create a report based on a query that contains the following fields memberNo, 

fName, lName, videoNo, title, dateOut and dateReturn. Group your records 
according to memberNo and then order by videoNo. 

 
Attempt to improve the appearance of your reports. Explore the other options 
available to you when creating a report and create more reports for use by 
StayHome. 
 
 
 
Creating a Customized Database Application 
 
A customized database application is a database created in a commercial package, 
such as Microsoft Access, using the tools that the commercial application provides to 
automate tasks and to replace the built-in interface elements with customized 
versions. A well-designed customized application is easy to learn and use because it 
presents, in clear, obvious, and intuitive ways only the instructions and commands 
needed to perform the specific tasks the database was designed to carry out.  
 
The following sections described how to create customized interface elements. 
 
Starting up your application 
 
A startup form will appear whenever someone opens your database. A startup form 
looks like any other database form, and can include text to identify the database and 
welcome users. 
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To create a startup form 
 
1.  You first create the form that is to be displayed when the database application is 

started. From the Insert menu, select Form. 
 
2.  In the New Form dialog box, double-click Design View. 
 
3.  Add the text you want to appear on the form. 
 
4.  Select the form by clicking on the form selector    located at the top left-hand-

side of the form.  
When selected, the form selector appears with a black box in the center.    
 

5.  Click on the Property button and change the following properties to make the 
form look like a dialog box. 

 
Scroll Bar (Neither)  Record selectors (No) 
Navigation Buttons (No)   Auto Center (Yes) 
 

6.  Save and name your form. An example of a startup form is shown in Figure P6-3. 
 
 

 
 
 
Figure P6-3: An example of a startup form for the StayHome database. 
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To open startup form automatically 
 
1.  From the Tools menu, select Startup to display the Startup dialog box. You can 

change the title and the image displayed in the title bar using the Application 
Title and Application Icon boxes, as shown in Figure P6-4. Note that icon files 
can be found in the C:\ Program Files\Microsoft Visual 
Studio\Common\Graphics\Icons folder.  

 
 

 
 

Figure P6-4: Startup dialog box. 
 
 
To bypass the startup form 
 
To bypass settings that determine how a database or application starts, hold down 
the SHIFT key when opening your database. 
 
 
Activity P6-2 
 
Create a startup form for the StayHome database called StayHome Startup (as 
shown in Figure P6-3). Ensure that this form is automatically displayed when you 
opened the database.  
 
 
 
 
Automating Repetitive Tasks 
 
When you set up a database, you will want it to be as easy to use as possible, 
especially when it comes to repetitive tasks. With Microsoft Access, it is easy to 
automate tasks like changing values in one field when the value in another changes 
or printing reports by creating macros or writing Visual Basic procedures. 
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Using Macros 
 
A macro automatically carries out a task or a series of tasks for you.  Each task that 
you want Microsoft Access to perform is called an action.  Microsoft Access provides 
a list of actions for you to select from to create a macro.  When you run the macro, 
Microsoft Access carries out the actions in the sequence they are listed, using the 
objects or data you have specified.   
 
To create a macro 
 
1.  In the Database window, click the Macros button and click New or from the Insert 

menu, select Macro. 
 

Microsoft Access opens a new Macro window, where you select the actions you 
want in the macro, as shown in Figure P6-5. 

 
 

 
 

 
Figure P6-4:  Creating a macro called Set Return Date in the Macro Window. 
 
 
2.  You use the upper portion of the Macro window to add actions. You can add 

comments to explain the reasoning behind each action. You use the lower portion 
of the Macro window to specify arguments for an action.  Arguments give 
Microsoft Access additional information on how to carry out an action, such as 
which object or data to use. 

 
There are two ways to add actions to a macro.  You can select actions from the 
action list in the Macro window, or for common actions associated with objects in 
your database, you can drag the object from the Database window to the action cell 
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in the Macro window.  This drag-and-drop method adds the appropriate action and 
arguments. 
 
To add an action to a macro 
 
1.  In the Macro window, click the first empty cell in the Action column. 
 
2.  Either select the action you want from the action list (click the arrow to see this 

list) or type the action directly in the cell. 
 
3.  Enter a comment (optional) for the action. 
 
4.  Specify the arguments for the action, if any are required. 
  
To save a macro 
 
You must save a macro before you can run it.  When you save a macro, it becomes 
a database object that you can open or run from the Database window. 
 
1.  From the Macro window, choose Save from the File menu. 
 
2.  If you are saving a macro for the first time, type a name for the macro and choose 
OK. 
 
Running a Macro 
 
You can run a macro from the Macro window, from the Database window, from other 
windows in the database, or from another macro.  You can also run a macro in 
response to an event that occurs in a form or report. 
 
To run a macro from the Macro window 
 
With the macro open in the Macro window, choose Run from the Run menu or click 
the Run button on the toolbar. 

To run a macro from the Database window 
 
In the Database window, click the Macro button and choose the Run button. 
 
To run a macro from other windows in the database 
 
1.  From the Tools menu, choose Macro and then Run Macro…. 
 
2.  In the Run Macro box, type the name of the macro you want to run and click OK. 
 
To run a macro from another macro 
 
1.  Add the RunMacro action to your macro. 
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2.  Set the Macro Name argument to the name of the macro you want to run. 
 
You can also run a macro in response to an event that occurs in a form or report, by 
setting the appropriate event property to the name of the macro.  For example, you 
can run a macro automatically when you open a form, use the form to add a new 
record, press a command button on the form, or close the form. 
 
Responding to Events on Forms 
 
When you use a form, Microsoft Access recognizes certain things that happen on the 
form as events.  For example, moving from one record to another on a form is an 
event; so is double-clicking a control.  You can use a macro to respond to an event.  
 
Each form and control event has a corresponding event property.  You specify how 
a control or the form responds to an event by using a macro: You set the appropriate 
event property for the form or control to the name of the macro. 
 
To create a response to an event, first you identify the form or control event you want  
the macro to respond to.  Next, you write a macro that contains the actions that are 
to take place when the event occurs and set the event property  to the name of the  
macro.  You can use the Macro Builder to create a macro and set the event 
automatically.  The Macro Builder is available for each event property. 
 
 
Activity P6-3 
 
(a) Create a macro called Set Return Date that automatically sets the value in the 

dateReturn field of the RentalAgreement table to two days after the value in the 
dateOut field. Open a form for the RentalAgreement table and associate the Set 
Return Date macro with the After Update event property of the dateOut field.  
Test the Set Return Date macro. 

 
(b)  Create a macro called Open Rental Agreement Form that opens up a form for 

the RentalAgreement table in data entry mode (Set Mode to Add). Save and 
close the macro. Open up a form for the Member table in Design View and 
ensure that you can also see the Database Window. Click on the Macros button 
on the Database Window and click and drag the Open Rental Agreement Form 
macro to the Member form. Drop the macro onto the form and note that a 
command button is created.  Save the form and test the Open Rental Agreement 
Form macro. 

 
(c)  Explore the other types of tasks that can be automated using macros. 
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Use the Command Button Wizard to Create the Button 
 
Using Microsoft Access, you can automate tasks by creating command buttons with 
the Command Button Wizard. A command button is a control on a form.  Unlike 
most other controls, a command button does not display or accept data.  Instead, 
when you press the button, it carries out an action such as printing reports or 
opening forms. 
 
If you often use two forms together, you can create a command button on one form 
that opens the other automatically. 
 
To create a button that closes a form 
 
1.  Open the form that is to contain the button in Design view. 

2.  Select the Command Button tool in the toolbox.      
 
3. Click an empty area in the form. Microsoft Access displays the first Command 

Button Wizard dialog box.  
 
4.  A command button can be use to carry out many tasks such as navigating through 

records, performing operations on records and running other run applications.  
 

To create a button that opens a form, select Form Operations and Open Form. 
Click the Next button. 

 
5. Complete the instructions in the following Command Button Wizard dialog boxes. 
 

Microsoft Access creates the command button and places it on the form. 
 
 
 
Activity P6-4 
 
(a)  Add a button to your startup form that when clicked closes the form. 
 
(b)  Add a command button to your VideoForm2 (created in Practical 3) that print 

previews the report created for Activity P6-1(a) of this practical.  
 
(c)  Create a form for the Member table that allows the user to add, delete and save 

records or to close the form.  
 
Explore the other types of tasks that can be automated using the Command Button 
Wizard. 
 
 
 
 
 
Programming in Visual Basic 
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When the Command Button Wizard creates a button, it actually writes a Visual Basic 
event procedure to perform the action you want. You can see the event procedure 
for a button by opening the button’s property sheet and examining the On Click 
property and clicking the  Build button.  
 
Using the Visual Basic programming language, you can edit or add to the 
instructions the Command Button Wizard creates, or you can write your own event 
driven procedures. For more information on event procedures search the online help. 
 
 
Activity P6-5  
 
Examine the Visual Basic code attached to the buttons that you created in Activity 
P6-4. Open the Microsoft Access sample database applications and examine the 
Visual Basic code associated with these applications.  
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Practical 7 
 
 
In this practical, we revisit some of the topics introduced in Practicals 1 to 6.  You will 
learn more about field and table properties, and about indexes including when it is 
appropriate to create them. You will also learn more about relationships and in 
particular referential integrity. You should first read the information given in this 
practical and then complete the activities listed throughout. 
 
 
Setting Field Properties  
 
You can control the appearance of data, prevent incorrect entries, specify default 
values, and speed up searching and sorting by setting field properties in a table’s 
Design view. For example, you can format numbers to make them easier to read, or 
you can set rules that data must meet to be entered in a field. 
 
Microsoft  Access  uses  field  property  settings  when  you  view  and  edit  data. 
The Format, Input Mask, and Caption properties you set appear in table and query 
datasheets, and controls on new forms and reports. You use other properties to set 
rules for  data  or  to  require data  entry  in  your  fields,  which  Microsoft  Access  
enforces  whenever  you  add  or  edit data in the table.  
 
Listed below are the field properties and their uses.  
 
 
Field Property Uses 
 
Field Size Adjust the size of a Text field, or limit the range of allowable 

values in a Number field. 
Format Display dates and numbers in a certain display format, such as 

Long Date format or Currency format. 
Decimal Places Display a certain number of places after the decimal point when 

using a format for a Number or Currency field. 
Input Mask Display formatting characters in a field so that they don’t have to 

be entered, and ensure that data entered fits in the mask. 
Caption Specify a label other than the default label (field name) for new 

forms and reports. 
Default Value Automatically fill in a certain value for a field in new records you 

add to the table. 
Validation Rule  Limit data entered in a field to values that meet certain 

requirements.  Microsoft Access checks to make sure the data 
follows this rule before it moves to the next field in the table. 

ValidationText Display a message when the field validation rule is violated. 
Required Require that data be entered in a field. 
Allow Zero Length Allow zero-length strings to be stored in a Text or Memo field. 
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Indexed Speed up searches on fields that  are  searched  frequently. 
Unicode Compression A character-encoding scheme to represent the data in a 

Text, Memo or Hyperlink field. In Unicode, each character is 
represented by two bytes instead a single byte.  

 
You view and change field properties for one field at a time.  When you open a table 
in Design view, Microsoft Access displays the property settings for the current field in 
the lower portion of the Table window. The particular field properties displayed for 
each field in your table will vary according to the field data type. 
 
To set a field property for a table 
 
1. Open the table in Design view. 
 
2. In the upper portion of the Table window, click the field for which you want to set 

properties. Microsoft Access displays the properties for this field in the lower 
portion of the Table window.   

 
3. In the lower portion of the window, click the box for the field property you want to 

set. 
 
4. Type a setting for the property.  Or, if an arrow appears at the right side of the 

property box, click the arrow to choose from a list of settings for the property. 
 
If you want more space to enter or edit a property setting, press SHIFT+F2 to display 
the zoom box.  If you are entering an input mask or validation expression and would 
like help building it, click the Build button to the right of the property box to display 
the appropriate builder. 
             
5.  To save your changes to the table, choose Save from the File menu or click the 

Save button on the toolbar. 

            
 
Activity P7-1 
 
In Practicals 1 and 2, you set field properties for some of the fields in your Member, 
RentalAgreement, VideoForRent, Video and Director tables. Examine the other fields 
in these tables, and add appropriate field properties. (At this stage, do not set the 
index property for your tables as later in this practical, we examine indexes in more 
detail.) 
 
Note that, you should use the builder, when entering an input mask or validation 
expression. 
 
 
 
 

 
 



©200, .Ibrahim I. Hamarash, MS-Access Lab Manual, Database Systems, Dept. of Software Eng., Erbil       
 
 

66

Setting Table Properties 
 
In addition to field properties, you can set properties that apply to an entire table and 
to entire records.  You set these properties in the table’s property sheet.  The list 
shown below gives the table properties and their uses.  
 
Table Property Uses 
 
Description Store a description of a table’s contents and purpose.  

For attached tables, Microsoft Access stores a 
description of the table’s source. 

Validation Rule Limit data entered in a record to values that meet 
certain requirements.  Microsoft Access checks to 
make sure the data follows this rule before it saves a 
record in the table. 

Validation Text Display a message when the record validation rule is 
violated. 

Filter Store a description of the filter for the table. 
Order By Store a description of the sort order for the records of 

the table. 
Subdatasheet Name  Specify the table or query (subdatasheet) that is 

bound to the table. A subdatasheet is a datasheet that 
is nested within another datasheet that contains data 
related or joined to the first datasheet. 

LinkChildFields / LinkMasterFields  Specify how Microsoft Access links records 
in the table to the subdatasheet.  If set, Microsoft 
Access automatically updates the related record in 
subdatasheet when you change to a new record in a 
table. 

Subdatasheet Height Specify the display height of a subdatasheet when 
expanded. 

Subdatasheet Expanded Specify the saved state of all subdatasheets within a 
table. 

 
 
To set a table property 
 
1.  Open the table in Design view. 
 
2.  From the View menu, choose Properties (or click the Properties button on the 

toolbar).  
 

           
 

Microsoft Access displays the table’s property sheet, as shown in Figure P7-1. 
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Figure P7-1:  Table property sheet for the Member table. 
 

3.  Click the box for the property you want to set. 
 
4.  Type a setting for the property. 
 

If you want more space to enter or edit a property setting, press SHIFT+F2 to 
display the Zoom box.  If you are setting the Validation Rule property to an 
expression and would like help building it, click the Build button to the right of the 
Validation Rule property box to display the Expression Builder. 

 
5.  To save your changes to the table, choose Save from the File menu. 
 
Using Validation Rules for Records 
 
Although you will usually set validation rules for individual fields, you may also want 
to set a rule that applies to a record as a whole.  When you set a validation rule for a 
table, Microsoft Access checks for valid data when you save or leave a record, rather 
than when you leave a field.  Unlike field validation rules, table validation rules can 
contain references to one or more fields in the table.  This makes them useful when 
you want to compare values in different fields.  For example, you can use a table 
validation rule to ensure that one field’s value is always greater than that of another 
in the same record. 
 
You create a table validation rule by setting the table’s Validation Rule property to an 
expression.  Each time you save a record, Microsoft Access evaluates the 
expression to make sure it’s true. 

 
 
Activity P7-2 
 
(a) Create a rule that all members must be at least 18 years old when they join the 

video shop. Set this rule as a table property for your Member table (as shown in 
the Figure P7-1). Please ensure that you understand how the validation 
expression works by accessing the online help. 
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(b) Create a subdatasheet for the Member table to display the video rentals 
associated with each member (as shown in Figure P7-1).  Save your Member 
table and examine the table in datasheet view.  

 
 
 
 
Creating Indexes 
 
If you often search a table or sort its records by a particular field, you can speed up 
these operations by creating an index for the field.  
 
 
 
To create an index 
 
1.  Open the table in Design view. 
 
2.  Select the field to be indexed and access the Indexed property for this field. This 

gives the following list of possible settings for the Indexed property. 
 
Indexed Property Setting   Meaning 
 
No  Don’t create an index on this field (or delete 

existing index). 
Yes (Duplicates OK) Create an index on this field. 
Yes (No Duplicates) Create a unique index on this field. 
 
If you create a unique index, Microsoft Access does not allow you to enter in a field a 
value that already exists in the same field for another record.  Microsoft Access 
automatically creates a unique index for primary keys but you may want to prohibit 
duplicate values in other fields, as well.   
 
For more information on unique indexes, search Help for ‘Indexed’. Note that, 
Microsoft Access also automatically creates indexes for fields involved in 
relationships between tables. 
 
 
Viewing and Editing Indexes 
 
If you want to see or edit a table’s indexes, you can open the Indexes window in the 
table’s Design view. 
 
To view and edit existing indexes 
 
1.  Open the table in Design view. 
 
2.  From the View menu, choose Indexes or click the Indexes button on the toolbar. 
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Microsoft Access displays the Indexes window.  If the table has a primary key, the 
primary key index is displayed along with any other indexes you have added, as 
shown in Figure P7-2. 
 
 

 
 
 

Figure P7-2:  Indexes window for the Member table. 
 
3.  Change indexes or index properties as desired.  To delete an index, delete its row 

in the Indexes window.  This action removes only the index, not the field itself.  
 
4.  To save changes to the table, choose Save from the File menu. 
 
Creating Multiple-Field Indexes 
 
If you think you will often search or sort by two or more specific fields at a time, you 
can create an index on multiple fields. For example, if you often set criteria for lName 
and fName fields in the same query, it makes sense to create an index on both 
fields. 
 
When you sort a table by a multiple-field index, Microsoft Access sorts first by the 
first field listed in the Indexes window. If there are records with duplicate values in 
the field, Microsoft Access sorts next by the second field listed, and so on.  
 
To create a multi-table index 
 
1.  Open the table in Design view. 
 
2.  Open the Indexes window. 
 
3.  Move to the Index Name column and enter the names of the index. Only include 

the index name in the first row. 
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4.  Move to the Field Name column and enter the names of the fields to be used in 
the index. Each field name is entered into a separate row. 

 
Note that, Microsoft Access treats all rows as part of the same index until it comes to 
a row containing another index name. 
 
 
Activity P7-3 
 
(a) Examine the indexes for your Member, RentalAgreement, VideoForRent, Video 

and Director tables.  
(b) Create a single field index for the Video table on the title field.   
(c) Create a multi-table field index for the Member table on the lName and fName 

fields (as shown in Figure P7-2). 
 
 
 
Setting Relationships Between Tables 
 
Because Microsoft Access is a relational database, you can use data from more than 
one table or query at a time.  If your database contains tables with related data, you 
can define the relationship in the database.  Microsoft Access uses relationships to: 
 
Create joins in new queries 
 
When you create a query and add related tables or queries for which you have 
specified a relationship, Microsoft Access automatically creates joins to relate the 
data in the query. 
 
Display related records in a subform or subreport 
 
A common use for a subform or subreport is to include records from a related table.  
When you drag and drop a form or report onto another form or report, Microsoft 
Access uses relationships to display the correct data in the subform or subreport.  
 
Enforce referential integrity 
 
This is to protect the relationship between tables when you add, change, or delete 
records. 
  
 
Viewing and Editing Existing Relationships 
 
When you add tables to a query or Relationship window, Microsoft Access 
automatically displays the relationships that have been defined between them. 
 
To view existing relationships for a table or query 
 
1.  From the Tools menu, choose Relationships. 
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2.  To view all the relationships defined in the database, choose the Show All from 
the Relationship menu or click on the Show All Relationships button on the 
toolbar. 

 
The Relationship window for the tables of the StayHome database is shown in 
Figure P7-3. 
 

 
 
 

Figure P7-3  The Relationship window for the tables of the StayHome 
database. 

 
 
To view all the relationships defined for a particular table, select the table and then 
choose Show Direct from the Relationship menu or click on the Show Direct 
Relationships button on the toolbar. 

To edit an existing relationship 
 
1.  Click on the relationship line that you want to edit and from the Relationships 

menu, choose Edit Relationship. Alternatively, you can double-click on the 
relationship line that you want to edit.  

 
Microsoft Access displays the Edit Relationship dialog box as shown in Figure P7-
4. 
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Figure P7-4:  Edit Relationship dialog box for relationship between Video and 

VideoForRent tables. 
 
 
2.  Set the relationship options and then choose OK. 
 
 
To delete a relationship or table 
 
1.  From the Tools menu, choose Relationships. 
 
2.  Click on the relationship line or table that you want to delete and then press the 

DEL key. 
 
 
Referential Integrity 
 
In some relationships, Microsoft Access can enforce referential integrity when you 
add or delete records in related tables. Referential integrity helps ensure that 
relationships between records are valid, and that you do not accidentally delete 
related data. Microsoft Access can enforce referential integrity when these  
conditions are met: 
 
• The matching field from the primary table is a primary key or has a unique  

index. 
 
• The related fields have the same data type.  
 
• Both the tables belong to the same Microsoft Access database.  If the tables 

are attached, they must belong to the same Microsoft Access database. 
 
Referential integrity cannot be enforced for attached tables from databases in other 
formats. 
 
When referential integrity is enforced, you must observe the following rules: 
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When you add a record to a related table and specify a value in the matching field(s), 
there must already be a record with this value in the primary table.  For example, 
when you add rental details to the RentalAgreement table, the videoNo and 
memberNo that you specify must exist in the VideoForRent and Member tables, 
respectively. In other words, you must add a video or member record to the 
appropriate tables before entering rental details. 
  
You cannot delete a record from a primary table if matching records exist in a related 
table.  For example, you cannot delete a record from the Member table if there are 
rental details associated with that member in the RentalAgreement table. (This 
restriction does not apply if you set the Cascade Delete option for the relationship.) 
 
If you want Microsoft Access to enforce these rules for a relationship, select the 
Enforce Referential Integrity option when you create the relationship.  If referential 
integrity is enforced and you break one of the rules with the related tables, Microsoft 
Access displays a message and does not allow the change. 
 
Relationship Types 
 
For relationships in which referential integrity is enforced, you specify whether the 
two tables you are relating have a one-to-many or one-to-one type of relationship.  
In a one-to-many relationship, the most common type of relationship, each record in 
the primary table can be associated with many records in the related table (each 
primary key value can appear many times in the related table).  For example, each 
video for rent or member can be associated with many rentals. 
 
In a one-to-one relationship, each record in the primary table can be associated with 
only one record in the related table.  To display a one-to-one relationship in the 
Relationship window, the matching fields on both sides of the relationship must be 
set as a primary key or have a unique index. 
 
Cascading Delete and Update Operations  
 
For relationships in which referential integrity is enforced, you can specify whether 
you want Microsoft Access to automatically ‘cascade’ delete and update operations 
for related records. If you select these options, delete and update operations that 
would normally break referential integrity rules are allowed. When you delete records 
or change primary key values in a table, Microsoft Access makes necessary in 
changes to related tables to preserve referential integrity.   
 
If you select Cascade Delete for a relationship, any time you delete records in the 
primary table, Microsoft Access automatically deletes related records in the related 
table. For example, if you delete a record from the Member table, all the member’s 
rental details are automatically deleted from the RentalAgreement table. When you 
delete records from a table with the Cascade Delete option set, Microsoft Access 
warns you that related records may also be deleted. 
 
If you select Cascade Update for a relationship, any time you change the primary 
key of a record in the primary table, Microsoft Access automatically changes the 
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primary key to the new value in all related records.  For example, if you change a 
video’s number in the Video table, the videoNo field in the RentalAgreement table is 
automatically updated for every one of that Video’s rentals so that the relationship is 
not broken.  Microsoft Access cascades updates without displaying any message. 
 
Join Types 
 
If you want to specify the type of join Microsoft Access should create in new queries, 
you can set the join type when you create the relationship.  For example, if you 
always want Microsoft Access to create an outer join between two related tables, you 
can specify this type of join. For information on join types, search Help for ‘joins’. 
 
 
 
 
Activity P7-4 
 
View the relationships between your Member, RentalAgreement, VideoForRent, 
Video and Director tables. Examine the properties on each relationship. In particular, 
explore the Enforce Referential Integrity option of the Edit Relationship dialog box 
including the Cascade Delete and Cascade Update options. Investigate how these 
options work by attempting to edit or delete your records.  
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Practical 8 
 
 
In this practical, you will learn how to create parameter queries. You will also learn 
how to create queries using the Structured Query Language (SQL), which is a 
language used in querying, updating, and managing relational databases. You 
should first read the information given in this practical and then complete the 
activities listed throughout this practical. 
 
We start this practical by presenting an overview of the types of queries provided by 
Microsoft Access.  
 
 
Microsoft Access Queries 
 
As well as select queries, you can also create many other types of useful queries using 
Microsoft Access. Table P8-1 presents a summary of the types of queries provided by 
Access.  
 
 

Query Type Description 
Select Query Asks a question or defines a set of 

criteria about the data in one or more 
tables. 

Parameter Query Displays one or more predefined 
dialog boxes that prompts the user for 
the parameter value (criteria). 

Find Matched Query Finds duplicate records in a single 
table. 

Find Unmatched Query Finds distinct records in related tables. 

Crosstab Query Allows large amounts of data to be 
summarized and presented in a 
compact spreadsheet format with row 
and column headings. 

Autolookup Query Automatically fills in certain field 
values for a new record. 

Action Query   
(including delete, append, update and 
make-table queries) 

Makes changes to many records in just 
one operation. Such changes include 
the ability to delete, append, or make 
changes to records in a table and also 
to create a new table. 

SQL Query  
(including union, pass-through, data-
definition, subquery SQL) 

Union SQL query combines matching 
fields from two or more tables. Pass-
through SQL query sends commands to 
an SQL database. Data-definition SQL 
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query creates, changes or deletes 
tables.  

 
Table P8-1:  Summary of Microsoft Access Query Types. 
 
Creating Parameter Queries 
 
If you frequently run the same select query but you change the criteria each time you 
run it, you can save time by creating a parameter query. When you run a parameter 
query, you do not have to open the Query window and make changes to the QBE 
grid; instead, Microsoft Access prompts you for criteria in the Enter Parameter Value 
dialog box.  
 
If you design a parameter query that prompts you for more than one criterion,  
Microsoft Access displays successive dialog boxes for each criterion. Note that you 
can enter values into the Enter Parameter Value dialog box, but you cannot enter 
expressions. 
 
To create a parameter query 
 
1. Create a query without using a Wizard, and add the tables you want. 
 
2. Drag the fields for the query  to the QBE grid. 
 
3. In the Criteria cell under each field you want to use as a parameter, enter a 

prompt enclosed in square brackets.  Microsoft Access displays this prompt when 
the query is run. The text of the prompt must be different from the field name, 
though it can include the field name. An example QBE grid for a parameter query 
is shown in Figure P8-1. 

 
 

 
 
 

Figure P8-1:  Creating a parameter query for the Video table. 
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4. Run the query by clicking the View button      or Run  button      button 
on the toolbar.  Microsoft Access displays the Enter Parameter Value dialog box, 
as shown in Figure P8-2. 
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Figure P8-2:  The Enter Parameter Value dialog box for the parameter query 
created in Figure P8-1. 

 
 
5 .  Enter a value, and then choose OK. 
 
Microsoft Access retrieves the data and displays the dynaset.  Or, if you have 
specified more than one parameter, Microsoft Access prompts you for the other 
parameters and then displays the dynaset. 
 
 
Prompting for Several Parameters 
 
You can also create queries that prompt you for several parameter values.  You can 
specify parameters in each of several fields, or multiple parameters in a single field. 
For example, to display the details of videos with a daily rental rate between certain 
maximum and minimum rate, we create a query that prompts you with two 
successive dialog boxes. The QBE grid for this query is shown in Figure P8-3. 
 
 

 
 
 

Figure P8-3:  Creating a parameter query for the Video table using multiple 
parameters in the dailyRental field. 
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When the query is run, Microsoft prompts you with successive dialog boxes. By 
entering the maximum and minimum rental rates into each dialog box, you specify 
the range of rental rates you want. 
 
 
Activity P8-1 
 
Create and save the following parameter queries: 
 
(a) To display the details of videos in a given category (as shown in Figure P8-1). 
(b) To display the details of one or more members given the last name. 
(c) To display the details of a member given the member’s number. 
(d) To display the details of one or more members given the first name and last 

name. 
(e) To display the member number, full name, and address of members who had 

rented out a video, between certain dates. 
(f) To display the details of videos with a daily rental rate between certain maximum 

and minimum limits (as shown in Figure P8-3). 
 
Create any other useful single or multi-parameter queries. 
 
 
 
 
Using SQL in Microsoft Access 
 
Structured Query Language (SQL) is a language often used in querying, updating, 
and managing relational databases.  Each query created in Microsoft Access has an 
associated SQL statement that defines the actions of that query. You can use SQL 
statements to: 
 
View and modify queries you created using the QBE grid 
For every query you create using the QBE grid in Design view, you can view and 
make changes to its SQL statement. 
 
Set properties  
You can use SQL statements when setting form and report properties, such as 
Record Source and Row Source. 
 
Create SQL-specific queries 
For some types of queries, you must use SQL statements. Union queries, pass-
through queries, and data-definition queries cannot be designed using the QBE grid. 
 
Create subqueries 
To create a  subquery,  you  use  the  QBE  grid,  but  you  enter an  SQL SELECT 
statement for criteria.  
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Using SQL to View and Modify Queries 
 
When you create a query with the QBE grid, Microsoft Access constructs the 
equivalent SQL statement behind the scenes.  You can view or modify the SQL 
statement, rather than use the QBE grid. After you make changes to the SQL 
statement, the changes are reflected in the QBE grid. 
 
To view or modify an SQL statement 
 
1.  Create a query, or open an existing query in Design view. 
 
2.  From the View menu, choose SQL View.  
 
Microsoft Access displays the query in SQL view.  This view is of the SQL statement 
that is equivalent to what you created in Design view. The SQL statement for the 
query created in Figure P8-1 is shown Figure P8-4. 
 
 

 
 
Figure P8-4:  SQL View of parameter query created in Figure P8-1. 
 
 
3.  If you want to make changes, enter the changes into the SQL statement. 
 
4.  To return to the QBE grid select from the View menu, choose Design View. 
 
The QBE grid reflects the changes you made. 
 
 
Activity P8-2 
 
Examine each of the queries you created for Activity P8-1 in SQL view.  If you have 
saved any queries created in earlier practicals, also examine these queries in SQL 
view. 
 
Now re-examine the queries for Activity P8-1(a) to (f) using the QBE grid. Convert 
your parameter queries into standard select queries by carrying out the following 
modifications (shown underlined) to these queries using the QBE grid and note the 
changes reflected in the corresponding SQL statement. Also, run the queries to 
ensure that they retrieve the correct information. 
 

(a) To display the details of videos in category ‘Comedy’ or ‘Children’. 
(b) To display the details of one or more members with ‘Smith’ as the last name. 
 
(c) To display the details of  member number  ‘4’. 
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(d) To display the details of one or more members with last name ‘Smith’ and first 
name ‘Lorna’. 

(e) To display the member number, full name, and address of members who have 
rented out  video number  ‘1’. 

(f) To display the details of videos with a daily rental rate that is less than 4.00. 
 
 
 
 
Creating Tables with Access SQL 
 
You can create tables in your database using the Access SQL. 
 
• CREATE TABLE table_name (field_name data_type [(field size)][, field_name 

data_type...]) creates a new table with the fields specified by a comma-separated 
list. (For field names with spaces enclose entries with in square brackets). The 
field_size entry is only optional for Text fields. 

 
• CONSTRAINTS index_name {PRIMARY KEY (field_name)|UNIQUE 

(field_name)| |FOREIGN KEY (field_name) REFERENCES foreign table 
[(foreign_field)]} creates an index on the field name that follows the expression. 
You can specify the index as a PRIMARYKEY or as an UNIQUE index. You can 
also establish a relationship between the field and the field of a foreign table with 
the REFERENCES foreign_table [foreign_field] entry. 

 
• ALTER TABLE allows you to add new fields (ADD COLUMN field_name...) or 

delete existing fields (DROP COLUMN field_name...). 
 
• DROP INDEX index_name ON table_name deletes the index from a table 

specified by table_name. 
 
• DROP TABLE table_name deletes a table from the database. 
 
Note that, the Access SQL statement must terminated with a semi-colon (;). 
 
The Access SQL statements to create tables called Branch and Staff are shown in 
Figures P8-5 and P8-6, respectively. 
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Figure P8-5: Creating the Branch table using Access SQL. 
 
 

 
 

Figure P8-6:  Creating the Staff table using Access SQL. 
 
 
Activity P8-3 
 
Open your StayHome database and create the Branch and Staff tables using Access 
SQL (as shown in Figures P8-5 and P8-6). Use the CONSTRAINT clause of the 
CREATE TABLE statement to create primary keys for the tables and to establish the 
relationship between these tables. 
 
 
 
 
 
Writing Select Queries in SQL 
 
When you create a select query using QBE, Access translates the QBE query into 
an Access SQL statement. Every select query begins with the SELECT statement. 
The syntax for the basic SQL SELECT statement is shown overleaf. 
 
 
SELECT [ALL|DISTINCT|DISTINCTROW] select_list 
 FROM table_names 
 [WHERE search_criteria] 
 [ORDER BY column_criteria [ASC|DESC]] 
 
The following list describes the purpose of the elements in the basic select 
statement. 
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• SELECT is the basic command that specifies the query. The select_list parameter 
determines the fields (columns) that are to be included in the results table of the 
query. When you design an Access QBE query, the select_list parameter is 
determined by the fields you add to the Field row in the Query grid. Only those 
fields with the Show box ticked are included in the select_list. Multiple fields are 
separated by commas. The optional ALL, DISTINCT and DISTINCTROW 
qualifiers determine how rows are handled. ALL specifies that all rows are to be 
included, DISTINCT and DISTINCTROW have a similar function in eliminating 
duplicate rows. 

 
• FROM table_name specifies the name or names of the table(s) that form the 

target of the query. The table_names parameter is created in Access QBE by the 
entries from the Show Table dialog box. Commas are used to separate multiple 
tables. 

 
• WHERE search_criteria determines which records from the select list are 

displayed The search_criteria parameter is an expression with a text (string) 
operator such as LIKE for text fields or a numeric operator such as >= for numeric 
values. The WHERE clause is optional and if absent all rows are retrieved. 

 
• ORDER BY column_criteria specifies the sorting order of the records in the results 

table. ORDER BY is optional. 
 
An example of a simple SQL statement to query the Video table and the resulting 
datasheet are shown in Figures P8-7 and P8-8, respectively. 
 
 

 
 

Figure P8-7:  Creating a Select query on the Video table using Access SQL. 
 
 

 
 
 

Figure P8-8:  The datasheet created on running the Select query shown in 
Figure P8-7. 
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Activity P8-4 
 
Using Access SQL, create simple select queries on the tables of your StayHome 
database. For example, create and save the following queries on the Video table. 
 
(a)  List the catalogNo, title and category of the Video table, ordered by video title (as 

shown in Figures P8-7 and P8-8). 
(b)  List title, certificate, category and dailyRental of the Video table for videos in the 

‘Childrens’ category with a rental rate less than £4.00.  
(c)   List all videos with a certification of ‘PG’ or ‘18’in the Video table. 
 
 
 
 
Using the SQL Aggregate Functions 
 
If you want to use the aggregate functions to determine totals, averages or statistical 
data for groups of records with a common attribute value, you add the GROUP BY 
clause. You can further limit the result of the GROUP BY clause with the optional 
HAVING qualifier. 
 
 SELECT [ALL|DISTINCT|DISTINCTROW] 
 aggregate_function (field_name) AS alias [, select_list] 
 FROM tables_names 
 [WHERE search_criteria] 
 [GROUP BY group_criteria] 
  [HAVING aggregate_criteria] 
 [ORDER BY column_criteria] 
 
The select_list includes the aggregate function with a field_name as its argument.  
 
• AS alias assigns a caption to the column. 
 
• GROUP BY group_criteria establishes the column on which the grouping is 

based.  
 
• HAVING aggregate_criteria is one or more criteria applied to the column that 

contains the aggregate function. The aggregate_criteria of the HAVING is applied 
after the grouping is complete. WHERE search_criteria operates before the 
grouping occurs. 

 
An example of a SQL statement using the aggregate functions (COUNT and SUM), 
and the GROUP BY and HAVING clauses to query the Videos table and the 
resulting table are shown in Figures P8-9 and P8-10, respectively. 
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Figure P8-9:  Creating an Aggregate query on the Video table using Access 
SQL. 

 
 

 
 
 
Figure P8-10:  The datasheet created on running the Aggregate query shown in 

Figure P8-9. 
 
 
Activity P8-5 
 
Using the Access SQL, create select queries on the tables of your StayHome 
database. For example, create and save the following queries on the Video table. 
 
(a)  For each video category, list the total number of videos, the total daily rental rate 

and total price of videos (as shown in Figures P8-9 and P8-10). 
(b)  List the total number of videos with a certification of ‘PG’ or ‘18’. 
(c)  List the maximum and minimum daily rental rate for videos in each category. 
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Creating Joins with SQL 
 
Joining two or more tables with Access QBE uses the JOIN_ON clause that 
specifies the tables to be joined and the relationship between the fields on which the 
join is based. 
 
 SELECT [ALL|DISTINCT|DISTINCTROW] 
 FROM tables_names 
 {INNER|LEFT|RIGHT} table_name JOIN join_table ON join_criteria 
 [{INNER|LEFT|RIGHT} table_name JOIN join_table ON join_criteria 
 [WHERE search_criteria] 
 [ORDER BY column_criteria] 
 
• table_name JOIN join_table specifies the name of the table that is joined with 

other tables listed in table_names. Each of the tables participating in a join must 
be included in the table_names list. 

 
One of the three types of joins, INNER, LEFT or RIGHT must precede the join 
statement. INNER specifies an equi-join: LEFT specifies a left outer join and 
RIGHT specifies a right outer join. 

 
• ON join_criteria specifies the two fields to be joined and the relationship between 

the two joined fields. The join_criteria expression contains an equal sign (=) 
comparison operator  and returns a true or false value. If the value of the 
expression is True, the record in the joined table is included in the query result. 

 
An example of an INNER JOIN (natural join) between the Member and 
RentalAgreement tables using Access SQL and the resulting datasheet are shown in 
Figures P8-11 and P8-12, respectively. 
 
 

 
 
 

Figure P8-11:  Creating an INNER JOIN between the Member and 
RentalAgreement tables. 
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Figure P8-12:  The datasheet created on running the Inner Join query shown in 
Figure P8-11. 
 
 
 
Activity P8-6 
 
(a) Using Access SQL, create an INNER (natural) join between the Member and 

RentalAgreement tables to display only the memberNo, fName, lName, rentalNo, 
dateOut and dateReturn fields (as shown in Figures P8-11 and P8-12). 

 
 Investigate the effect of changing the join type between the Member and 

RentalAgreement tables to a LEFT (outer) join and then to a RIGHT (outer) join. 
 
(b) Create an INNER (natural) join between the VideoForRent, RentalAgreement 

and Member tables to display only the catalogNo, videoNo, dateOut, dateReturn, 
memberNo, fName and lName fields. 

 
 
 
Creating Subqueries 
 
A   subquery  is an SQL  SELECT statement inside another select query. You can 
create a subquery that defines a field, or you can use a subquery to define criteria for 
a field. 
 
In many cases, SQL statements that include subqueries can be formulated either as 
a join or as one query based on another.  For example, say you wanted to find all 
videos with a daily rental rate the same as the rental rate of  a video called 
‘Independence Day’.  You can create one query that finds the daily rental rate of  
‘Independence Day’.  Then you can create another query based on the first query.  
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The second query finds all videos with the same rental rate as that found in the first 
query.  Or you can create a subquery that performs everything in one operation.  
 
You can write a SELECT query that uses another SELECT query to supply the 
criteria for the WHERE clause. The general syntax of a subquery is as follows. 
 
SELECT field_list 
 FROM tables_list 
 [WHERE [table.name.]field_name 

IN SELECT select statement 
 [GROUP BY group_criteria] 
  [HAVING aggregate_criteria] 
 [ORDER BY column_criteria] 
 
 
An example of a subquery and the resulting datasheet is shown in Figures P8-13 
and P8-14. 
 
 

 
 
 

Figure P8-13:  An example of a  Subquery (nested query) on the Video, 
VideoForRent and RentalAgreement tables. 

 
 

 
 
 
Figure P8-14:  The datasheet created on running the Subquery shown in Figure 

P8-12. 
 
For more information on the syntax  for  subqueries  and  useful examples of 
subqueries, search Help for ‘SQL: subqueries’. 
 
Activity P8-7 
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Using the Access SQL, create select subqueries on the tables of your StayHome 
database. For example, create and save the following queries. 
 
(a)  List the catalogNo, title and category fields of the Video table for those videos 

that were rented out between the 1st January 99 and the 1st January 00 (as 
shown in Figures P8-13 and P8-14). 

(b)  List the details of the videos with a certification of ‘PG’ or ‘18’ that were rented 
out to  member number ‘3’. 

(c)  List the videoNo, dateOut and dateReturn fields of the RentalAgreement table for 
videos with a certification ‘U’. 

 
 
 
Activity P8-8 
 
Return to Table P8-1 of this practical and examine the range of queries provided by 
Microsoft Access. Ensure that you understand the purpose of each type of query and 
attempt to create and run some of the queries not covered in detail in this practical. 
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